aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-06-23 22:42:32 +0800
committerjbeich <jbeich@FreeBSD.org>2018-06-23 22:42:32 +0800
commit71659f1800801b69f716f66f70cb3dbf3d267aaf (patch)
tree2c97c0689cb8a4c2faba69fe2b7841928e89e96f /devel
parent1c1f1591329e3af7231d4e1a4262558748b2c8ae (diff)
downloadfreebsd-ports-gnome-71659f1800801b69f716f66f70cb3dbf3d267aaf.tar.gz
freebsd-ports-gnome-71659f1800801b69f716f66f70cb3dbf3d267aaf.tar.zst
freebsd-ports-gnome-71659f1800801b69f716f66f70cb3dbf3d267aaf.zip
devel/git-cinnabar: unbreak after r473036
./helper/cinnabar-fast-import.c:127:10: warning: implicit declaration of function 'pool_calloc' is invalid in C99 [-Wimplicit-function-declaration] marks = pool_calloc(1, sizeof(struct mark_set)); ^ ./helper/cinnabar-fast-import.c:127:8: warning: incompatible integer to pointer conversion assigning to 'struct mark_set *' from 'int' [-Wint-conversion] marks = pool_calloc(1, sizeof(struct mark_set)); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./helper/cinnabar-fast-import.c:131:12: warning: implicit declaration of function 'pool_alloc' is invalid in C99 [-Wimplicit-function-declaration] rc_free = pool_alloc(cmd_save * sizeof(*rc_free)); ^ ./helper/cinnabar-fast-import.c:131:10: warning: incompatible integer to pointer conversion assigning to 'struct recent_command *' from 'int' [-Wint-conversion] rc_free = pool_alloc(cmd_save * sizeof(*rc_free)); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./helper/cinnabar-fast-import.c:136:2: warning: implicit declaration of function 'prepare_packed_git' is invalid in C99 [-Wimplicit-function-declaration] prepare_packed_git(); ^ ./helper/cinnabar-fast-import.c:138:30: error: too few arguments to function call, expected 2, have 1 install_packed_git(pack_data); ~~~~~~~~~~~~~~~~~~ ^ ./packfile.h:38:1: note: 'install_packed_git' declared here extern void install_packed_git(struct repository *r, struct packed_git *pack); ^ ./helper/cinnabar-fast-import.c:139:34: error: use of undeclared identifier 'packed_git_mru' list_add_tail(&pack_data->mru, &packed_git_mru); ^ ./helper/cinnabar-fast-import.c:155:23: error: too few arguments to function call, single argument 'r' was not specified reprepare_packed_git(); ~~~~~~~~~~~~~~~~~~~~ ^ ./packfile.h:37:1: note: 'reprepare_packed_git' declared here extern void reprepare_packed_git(struct repository *r); ^ ./helper/cinnabar-fast-import.c:194:28: error: use of undeclared identifier 'packed_git' for (prev = NULL, pack = packed_git; pack; ^ ./helper/cinnabar-fast-import.c:201:5: error: must use 'struct' tag to refer to type 'packed_git' packed_git = pack->next; ^ struct ./helper/cinnabar-fast-import.c:201:5: error: expected expression ./helper/cinnabar-fast-import.c:239:24: warning: incompatible pointer types passing 'unsigned char const[20]' to parameter of type 'const struct object_id *' [-Wincompatible-pointer-types] if (!get_tree_entry(note->hash, path, oid.hash, &mode)) ^~~~~~~~~~ ./tree-walk.h:82:44: note: passing argument to parameter here int get_tree_entry(const struct object_id *, const char *, struct object_id *, unsigned *); ^ ./helper/cinnabar-fast-import.c:239:42: warning: incompatible pointer types passing 'unsigned char [20]' to parameter of type 'struct object_id *' [-Wincompatible-pointer-types] if (!get_tree_entry(note->hash, path, oid.hash, &mode)) ^~~~~~~~ ./tree-walk.h:82:78: note: passing argument to parameter here int get_tree_entry(const struct object_id *, const char *, struct object_id *, unsigned *); ^ ./helper/cinnabar-fast-import.c:250:13: warning: implicit declaration of function 'sha1_object_info' is invalid in C99 [-Wimplicit-function-declaration] e->type = sha1_object_info(note->hash, NULL); ^ ./helper/cinnabar-fast-import.c:411:19: warning: implicit declaration of function 'read_sha1_file_extended' is invalid in C99 [-Wimplicit-function-declaration] char *content = read_sha1_file_extended(note->hash, &type, &len, 0); ^ ./helper/cinnabar-fast-import.c:411:9: warning: incompatible integer to pointer conversion initializing 'char *' with an expression of type 'int' [-Wint-conversion] char *content = read_sha1_file_extended(note->hash, &type, &len, 0); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./helper/cinnabar-fast-import.c:423:12: warning: incompatible integer to pointer conversion assigning to 'char *' from 'int' [-Wint-conversion] content = read_sha1_file_extended(git_id->hash, &type, ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./helper/cinnabar-fast-import.c:489:13: warning: implicit declaration of function 'sha1_object_info' is invalid in C99 [-Wimplicit-function-declaration] } else if (sha1_object_info(git_id.hash, NULL) != type) { ^ ./helper/cinnabar-fast-import.c:513:10: warning: implicit declaration of function 'sha1_object_info' is invalid in C99 [-Wimplicit-function-declaration] switch (sha1_object_info(note_oid->hash, NULL)) { ^ 13 warnings and 6 errors generated. Changes: https://github.com/glandium/git-cinnabar/compare/0.5.0b3...aaabee0 Reported by: pkg-fallout
Diffstat (limited to 'devel')
-rw-r--r--devel/git-cinnabar/Makefile4
-rw-r--r--devel/git-cinnabar/distinfo6
2 files changed, 5 insertions, 5 deletions
diff --git a/devel/git-cinnabar/Makefile b/devel/git-cinnabar/Makefile
index 259e8c5fa1ee..54da73e2230e 100644
--- a/devel/git-cinnabar/Makefile
+++ b/devel/git-cinnabar/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= git-cinnabar
-DISTVERSION= 0.5.0b3
-PORTREVISION= 1
+DISTVERSION= 0.5.0b3-2
+DISTVERSIONSUFFIX= -gaaabee0
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
diff --git a/devel/git-cinnabar/distinfo b/devel/git-cinnabar/distinfo
index c7bde6f6eeb6..dca2f8a7f522 100644
--- a/devel/git-cinnabar/distinfo
+++ b/devel/git-cinnabar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526703254
-SHA256 (glandium-git-cinnabar-0.5.0b3_GH0.tar.gz) = 23e8e26b53c0d3698d3c1a9fb512b49edf7321c4b77c4a09900b85e164ed0fcc
-SIZE (glandium-git-cinnabar-0.5.0b3_GH0.tar.gz) = 120153
+TIMESTAMP = 1529764737
+SHA256 (glandium-git-cinnabar-0.5.0b3-2-gaaabee0_GH0.tar.gz) = 65a73d4d9e89a3ccc0466e421954d8774c62ad6425485ac0525081bbb791f162
+SIZE (glandium-git-cinnabar-0.5.0b3-2-gaaabee0_GH0.tar.gz) = 120188