aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-03 14:16:03 +0800
committerclsung <clsung@FreeBSD.org>2006-08-03 14:16:03 +0800
commit7664e2b76fd29d59b335597281177c86fa0b8a12 (patch)
tree13a4093334f57a60c88a852a42c1dfe7a3dc5d8d /devel
parent03866b40c9cf516bc13d0338a7cee82973913a88 (diff)
downloadfreebsd-ports-gnome-7664e2b76fd29d59b335597281177c86fa0b8a12.tar.gz
freebsd-ports-gnome-7664e2b76fd29d59b335597281177c86fa0b8a12.tar.zst
freebsd-ports-gnome-7664e2b76fd29d59b335597281177c86fa0b8a12.zip
Add p5-SVN-Agent 0.02, simple svn manipulation.
PR: ports/100136 Submitted by: Yuan-Chung Hsiao <ychsiao at ychsiao.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-Agent/Makefile33
-rw-r--r--devel/p5-SVN-Agent/distinfo3
-rw-r--r--devel/p5-SVN-Agent/pkg-descr7
-rw-r--r--devel/p5-SVN-Agent/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d4945c206d07..31bdcf25e2c8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1278,6 +1278,7 @@
SUBDIR += p5-SPOPS
SUBDIR += p5-SSN-Validate
SUBDIR += p5-SVN-ACL
+ SUBDIR += p5-SVN-Agent
SUBDIR += p5-SVN-Log
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
diff --git a/devel/p5-SVN-Agent/Makefile b/devel/p5-SVN-Agent/Makefile
new file mode 100644
index 000000000000..535d93de25f0
--- /dev/null
+++ b/devel/p5-SVN-Agent/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-SVN-Agent
+# Date created: 2006-07-12
+# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Agent
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.org
+COMMENT= Simple svn manipulation
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Agent.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= currently requires at least Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-SVN-Agent/distinfo b/devel/p5-SVN-Agent/distinfo
new file mode 100644
index 000000000000..263dbb9bae00
--- /dev/null
+++ b/devel/p5-SVN-Agent/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Agent-0.02.tar.gz) = 1abdb0277b64554a1255d748bad55aaa
+SHA256 (SVN-Agent-0.02.tar.gz) = 400e49540d173055d86cddbaa61671d18c8196d53359ac2a531494fe893c83e6
+SIZE (SVN-Agent-0.02.tar.gz) = 10900
diff --git a/devel/p5-SVN-Agent/pkg-descr b/devel/p5-SVN-Agent/pkg-descr
new file mode 100644
index 000000000000..1a381f924f39
--- /dev/null
+++ b/devel/p5-SVN-Agent/pkg-descr
@@ -0,0 +1,7 @@
+This module provides regular svn operations on check out directory.
+It tries to do this in a simplest form possible. All operations are
+currently performed by running svn binary directly. Thus it is
+probably unportable. For a much more powerful way of working with
+svn repository see SVN::Client.
+
+WWW: http://search.cpan.org/dist/SVN-Agent/
diff --git a/devel/p5-SVN-Agent/pkg-plist b/devel/p5-SVN-Agent/pkg-plist
new file mode 100644
index 000000000000..49527cb21874
--- /dev/null
+++ b/devel/p5-SVN-Agent/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SVN/Agent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Agent/.packlist
+@dirrmtry %%SITE_PERL%%/SVN
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Agent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN