aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-27 15:14:43 +0800
committermiwi <miwi@FreeBSD.org>2007-03-27 15:14:43 +0800
commit776ba52b83ee7fc49376b654b188a72eab71626a (patch)
treeaf60aca71ead7acadef11fb92c966f949a340183 /devel
parent9d9a470406d56a0f7cc036b4550286b5bc0db616 (diff)
downloadfreebsd-ports-gnome-776ba52b83ee7fc49376b654b188a72eab71626a.tar.gz
freebsd-ports-gnome-776ba52b83ee7fc49376b654b188a72eab71626a.tar.zst
freebsd-ports-gnome-776ba52b83ee7fc49376b654b188a72eab71626a.zip
Gearman is a system to farm out work to other machines, dispatching function
calls to machines that are better suited to do work, to do work in parallel, to load balance lots of function calls, or to call functions between languages. This is the Perl client component. WWW: http://www.danga.com/gearman/ PR: ports/110876 Submitted by: Vivek Khera <vivek at khera.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Gearman/Makefile39
-rw-r--r--devel/p5-Gearman/distinfo3
-rw-r--r--devel/p5-Gearman/pkg-descr8
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 457c3deb566d..25c516e6cc2f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1165,6 +1165,7 @@
SUBDIR += p5-Filter
SUBDIR += p5-Filter-Template
SUBDIR += p5-FreezeThaw
+ SUBDIR += p5-Gearman
SUBDIR += p5-Geo-ShapeFile
SUBDIR += p5-Getargs-Long
SUBDIR += p5-Getopt-ArgvFile
diff --git a/devel/p5-Gearman/Makefile b/devel/p5-Gearman/Makefile
new file mode 100644
index 000000000000..f6c76e7de27e
--- /dev/null
+++ b/devel/p5-Gearman/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Gearman
+# Date created: Mon Mar 26 11:45:06 EDT 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gearman
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/B/BR/BRADFITZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Gearman client libraray for Perl
+
+MODULE_DEPENDS= p5-String-CRC32>=0.0:${PORTSDIR}/devel/p5-String-CRC32
+RUN_DEPENDS+= ${MODULE_DEPENDS}
+BUILD_DEPENDS+= ${MODULE_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Gearman::Client.3 Gearman::Task.3 Gearman::Worker.3
+PLIST_FILES= %%SITE_PERL%%/Gearman/Client.pm \
+ %%SITE_PERL%%/Gearman/JobStatus.pm \
+ %%SITE_PERL%%/Gearman/Objects.pm \
+ %%SITE_PERL%%/Gearman/ResponseParser.pm \
+ %%SITE_PERL%%/Gearman/ResponseParser/Taskset.pm \
+ %%SITE_PERL%%/Gearman/Task.pm \
+ %%SITE_PERL%%/Gearman/Taskset.pm \
+ %%SITE_PERL%%/Gearman/Util.pm \
+ %%SITE_PERL%%/Gearman/Worker.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gearman/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gearman \
+ %%SITE_PERL%%/Gearman/ResponseParser \
+ %%SITE_PERL%%/Gearman
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Gearman/distinfo b/devel/p5-Gearman/distinfo
new file mode 100644
index 000000000000..3d0f7c708207
--- /dev/null
+++ b/devel/p5-Gearman/distinfo
@@ -0,0 +1,3 @@
+MD5 (Gearman-1.02.tar.gz) = b46020d0838fccd516e2b65b88adf587
+SHA256 (Gearman-1.02.tar.gz) = e24ffb70deff76f6583c3c79e765bc3658485f981a221221f6a49d6496f134df
+SIZE (Gearman-1.02.tar.gz) = 15877
diff --git a/devel/p5-Gearman/pkg-descr b/devel/p5-Gearman/pkg-descr
new file mode 100644
index 000000000000..18fd3a7e7ac8
--- /dev/null
+++ b/devel/p5-Gearman/pkg-descr
@@ -0,0 +1,8 @@
+Gearman is a system to farm out work to other machines, dispatching function
+calls to machines that are better suited to do work, to do work in parallel,
+to load balance lots of function calls, or to call functions between
+languages.
+
+This is the Perl client component.
+
+WWW: http://www.danga.com/gearman/