aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
committerbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
commit7b5950ceb07fbf7baff9cf5f999cb870df39056d (patch)
tree293dcbc9c7e5b5460095f0f0b868e1ead9528ded /devel
parentce8f3833463574b1140cd020d12c0b68cfcb0d83 (diff)
downloadfreebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.gz
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.zst
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.zip
Introduce ICONV_CONFIGURE_ARG variable defined at Uses/iconv.mk.
It's value is "--with-libiconv-prefix=/usr/local" for systems before 100043 with ports libiconv and to use at systems post 100043 with base iconv it's value is "" (NULL). Co-authors: bapt, madpilot and bsam (me)
Diffstat (limited to 'devel')
-rw-r--r--devel/cross-gcc/Makefile4
-rw-r--r--devel/gdb/Makefile2
-rw-r--r--devel/gdb66/Makefile6
-rw-r--r--devel/gmake/Makefile4
-rw-r--r--devel/libhtp/Makefile9
-rw-r--r--devel/mingw32-gcc/Makefile2
-rw-r--r--devel/motor/Makefile2
-rw-r--r--devel/msp430-gcc/Makefile2
-rw-r--r--devel/popt/Makefile2
9 files changed, 12 insertions, 21 deletions
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index dc9200a14d1f..6ded5fdc7cfb 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS?= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
USE_BZIP2= yes
USE_GMAKE= yes
-USES= bison
+USES= bison iconv
STRIP= #empty
GNU_CONFIGURE= yes
ALL_TARGET= all info
@@ -61,7 +61,7 @@ CONFIGURE_ARGS= --target=${OURTARGET} \
--datadir="${TGT_DATADIR}" \
--with-system-zlib \
--disable-nls \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--without-included_gettext \
--with-newlib \
--with-dwarf2 \
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index d320dfd6df31..a9dc9821bb02 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
--with-gdb-datadir=${PREFIX}/share/gdb${PORTVERSION:S/.//g} \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--without-libunwind-ia64 \
--enable-targets=all
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 1d91e5dd5a4d..4d98b082dd1f 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
--enable-target=all \
- --enable-tui
+ --enable-tui ${ICONV_CONFIGURE_ARG}
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
@@ -38,10 +38,6 @@ MAN1= gdb${VER}.1
.include <bsd.port.options.mk>
-.if empty(ICONV_LIB)
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
-.endif
-
.if ${PORT_OPTIONS:MINSIGHT}
PKGNAMESUFFIX= -insight
USE_TK= 84+
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index 8c0a42640025..15ac57ec7877 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -24,8 +24,8 @@ OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
+USES+= gettext iconv
+CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} \
--with-libintl-prefix=${LOCALBASE}
PLIST_SUB= NLS=""
.else
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index bf619530164f..901042dc8844 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -18,17 +18,12 @@ ACLOCAL_ARGS= -Im4
USE_LDCONFIG= yes
USES= pkgconfig pathfix iconv
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
${ICONV_LIB}
-.include <bsd.port.pre.mk>
-
-.if empty(ICONV_LIB)
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
-.endif
-
pre-configure:
@${REINPLACE_CMD} -Ee 's,^(pkgconfigdir = ).*,\1$$(exec_prefix)/libdata/pkgconfig,' ${WRKSRC}/Makefile.am
@cd ${WRKSRC} && ${SH} ./autogen.sh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index a8d8dd315edc..b3e9515f1a97 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -61,7 +61,7 @@ CONFIGURE_ARGS= --disable-nls --target=${GCC_TARG} \
--enable-libstdcxx-debug \
--disable-build-poststage1-with-cxx \
--enable-version-specific-runtime-libs \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--includedir=${PREFIX}/${GCC_TARG}/include \
--datadir=${PREFIX}/${GCC_TARG}/share \
--with-system-zlib
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index 2b411f7b9bc1..05f8b314aee6 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -14,7 +14,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USES= iconv
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
.include <bsd.port.options.mk>
diff --git a/devel/msp430-gcc/Makefile b/devel/msp430-gcc/Makefile
index ec2609b6618e..82f7d533535d 100644
--- a/devel/msp430-gcc/Makefile
+++ b/devel/msp430-gcc/Makefile
@@ -56,7 +56,7 @@ CONFIGURE_ARGS+=--target=${PKGNAMEPREFIX:S/-$//} \
--enable-languages=c,c++ \
--enable-lto \
--with-gmp=${LOCALBASE} --with-mpfr=${LOCALBASE} \
- --with-mpc=${LOCALBASE} --with-libiconv-prefix=${LOCALBASE} \
+ --with-mpc=${LOCALBASE} ${ICONV_CONFIGURE_ARG} \
--with-system-zlib --disable-nls \
--with-pkgversion="MSPGCC_${LTSVERSION}"
INFO_PATH= ${PKGNAMEPREFIX:S/-$//}/info
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index 8d48c0653218..e99abf6b779c 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://rpm5.org/files/popt/
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= A getopt(3) like library with a number of enhancements, from Redhat
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} \
--program-prefix=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib