aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-06-21 15:51:54 +0800
committerpi <pi@FreeBSD.org>2018-06-21 15:51:54 +0800
commit7b9fd4c3ab7953923dc47ba388938043707cf6b0 (patch)
treeec12f8973638bd478c9c41b3822a7e0150c9b640 /devel
parent0b4025c6e1ee3b1206e263698e06030f55d1302a (diff)
downloadfreebsd-ports-gnome-7b9fd4c3ab7953923dc47ba388938043707cf6b0.tar.gz
freebsd-ports-gnome-7b9fd4c3ab7953923dc47ba388938043707cf6b0.tar.zst
freebsd-ports-gnome-7b9fd4c3ab7953923dc47ba388938043707cf6b0.zip
New port: devel/p5-Test-Mock-Redis
Test::Mock::Redis can be used in place of Redis for running tests without needing a running redis instance. This module is designed to function as a drop in replacement for Redis.pm for testing purposes. WWW: https://metacpan.org/release/Test-Mock-Redis PR: 229196 Submitted by: Tomohiro Hosaka <bokutin@bokut.in>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Mock-Redis/Makefile29
-rw-r--r--devel/p5-Test-Mock-Redis/distinfo3
-rw-r--r--devel/p5-Test-Mock-Redis/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 096dc809f675..6d528d4885fd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3555,6 +3555,7 @@
SUBDIR += p5-Test-Mock-Guard
SUBDIR += p5-Test-Mock-LWP
SUBDIR += p5-Test-Mock-LWP-Dispatch
+ SUBDIR += p5-Test-Mock-Redis
SUBDIR += p5-Test-MockDateTime
SUBDIR += p5-Test-MockModule
SUBDIR += p5-Test-MockObject
diff --git a/devel/p5-Test-Mock-Redis/Makefile b/devel/p5-Test-Mock-Redis/Makefile
new file mode 100644
index 000000000000..27460cb1b47e
--- /dev/null
+++ b/devel/p5-Test-Mock-Redis/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= Test-Mock-Redis
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Use in place of Redis for unit testing
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Module-Build>=0.4:devel/p5-Module-Build \
+ p5-Test-Deep>=0:devel/p5-Test-Deep \
+ p5-Test-Deep-UnorderedPairs>=0:devel/p5-Test-Deep-UnorderedPairs \
+ p5-Test-Fatal>=0:devel/p5-Test-Fatal
+RUN_DEPENDS= p5-Class-Method-Modifiers>=0:devel/p5-Class-Method-Modifiers \
+ p5-Package-Stash>=0.34:devel/p5-Package-Stash \
+ p5-Try-Tiny>=0:lang/p5-Try-Tiny \
+ p5-namespace-clean>=0:devel/p5-namespace-clean
+
+USES= perl5
+USE_PERL5= modbuild
+PLIST_FILES= ${SITE_PERL_REL}/Test/Mock/Redis.pm \
+ ${SITE_MAN3_REL}/Test::Mock::Redis.3.gz
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Mock-Redis/distinfo b/devel/p5-Test-Mock-Redis/distinfo
new file mode 100644
index 000000000000..21fed64a55db
--- /dev/null
+++ b/devel/p5-Test-Mock-Redis/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529538406
+SHA256 (Test-Mock-Redis-0.20.tar.gz) = ad00d999a808ca23c05c7ea2f198ba73fe93ff4d9646486078c647457a72ead4
+SIZE (Test-Mock-Redis-0.20.tar.gz) = 31965
diff --git a/devel/p5-Test-Mock-Redis/pkg-descr b/devel/p5-Test-Mock-Redis/pkg-descr
new file mode 100644
index 000000000000..904256123f26
--- /dev/null
+++ b/devel/p5-Test-Mock-Redis/pkg-descr
@@ -0,0 +1,6 @@
+Test::Mock::Redis can be used in place of Redis for running tests
+without needing a running redis instance. This module is designed
+to function as a drop in replacement for Redis.pm for testing
+purposes.
+
+WWW: https://metacpan.org/release/Test-Mock-Redis