aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2008-02-23 04:54:25 +0800
committerskv <skv@FreeBSD.org>2008-02-23 04:54:25 +0800
commit7db71209c96c79b468c6fed2cf982e896e2b3d0c (patch)
treef9d1554f75a510f7976508aa1a8457e4bfe39af0 /devel
parente08f5af80af2bfdbe9666549a63646939cd69439 (diff)
downloadfreebsd-ports-gnome-7db71209c96c79b468c6fed2cf982e896e2b3d0c.tar.gz
freebsd-ports-gnome-7db71209c96c79b468c6fed2cf982e896e2b3d0c.tar.zst
freebsd-ports-gnome-7db71209c96c79b468c6fed2cf982e896e2b3d0c.zip
Add p5-Class-StrongSingleton 0.02, a stronger and more secure Singleton
base class.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-StrongSingleton/Makefile22
-rw-r--r--devel/p5-Class-StrongSingleton/distinfo3
-rw-r--r--devel/p5-Class-StrongSingleton/pkg-descr7
-rw-r--r--devel/p5-Class-StrongSingleton/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a19f631bae84..663fd315e8e8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -995,6 +995,7 @@
SUBDIR += p5-Class-Spiffy
SUBDIR += p5-Class-StateMachine
SUBDIR += p5-Class-Std
+ SUBDIR += p5-Class-StrongSingleton
SUBDIR += p5-Class-Tangram
SUBDIR += p5-Class-Throwable
SUBDIR += p5-Class-Tom
diff --git a/devel/p5-Class-StrongSingleton/Makefile b/devel/p5-Class-StrongSingleton/Makefile
new file mode 100644
index 000000000000..b33694291386
--- /dev/null
+++ b/devel/p5-Class-StrongSingleton/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Class-StrongSingleton
+# Date created: 22 February 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-StrongSingleton
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/ST/STEVAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= A stronger and more secure Singleton base class
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::StrongSingleton.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-StrongSingleton/distinfo b/devel/p5-Class-StrongSingleton/distinfo
new file mode 100644
index 000000000000..378b7063c5cf
--- /dev/null
+++ b/devel/p5-Class-StrongSingleton/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-StrongSingleton-0.02.tar.gz) = 3f39892b065b1a7b23139f54054c77b4
+SHA256 (Class-StrongSingleton-0.02.tar.gz) = 48fb06d3936c70e9d31288bbed08d05dd54913dc7e6083dc55d2f35c172f77b6
+SIZE (Class-StrongSingleton-0.02.tar.gz) = 6347
diff --git a/devel/p5-Class-StrongSingleton/pkg-descr b/devel/p5-Class-StrongSingleton/pkg-descr
new file mode 100644
index 000000000000..0dd45ef305e8
--- /dev/null
+++ b/devel/p5-Class-StrongSingleton/pkg-descr
@@ -0,0 +1,7 @@
+This module is an alternative to Class::Singleton and
+Class::WeakSingleton, and provides a more secure Singleton class in that
+it takes steps to prevent the possibility of accidental creation of
+multiple instances and/or the overwriting of existsing Singleton
+instances.
+
+WWW: http://search.cpan.org/dist/Class-StrongSingleton/
diff --git a/devel/p5-Class-StrongSingleton/pkg-plist b/devel/p5-Class-StrongSingleton/pkg-plist
new file mode 100644
index 000000000000..3eaa241bdaa9
--- /dev/null
+++ b/devel/p5-Class-StrongSingleton/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/StrongSingleton/.packlist
+%%SITE_PERL%%/Class/StrongSingleton.pm
+@dirrmtry %%SITE_PERL%%/Class
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/StrongSingleton
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class