aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 13:46:38 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 13:46:38 +0800
commit7dd6805c44bf98d4d64a54313e9f622fd7cb2656 (patch)
tree753b016f246dce9957c268962733d34c7e3eb7b7 /devel
parentc4fd09e68bc5c2ee1078b7b21b2ac0601f34aead (diff)
downloadfreebsd-ports-gnome-7dd6805c44bf98d4d64a54313e9f622fd7cb2656.tar.gz
freebsd-ports-gnome-7dd6805c44bf98d4d64a54313e9f622fd7cb2656.tar.zst
freebsd-ports-gnome-7dd6805c44bf98d4d64a54313e9f622fd7cb2656.zip
PERL -> REINPLACE
And some ports have USE_PERL5=yes now.
Diffstat (limited to 'devel')
-rw-r--r--devel/cvsgraph/Makefile5
-rw-r--r--devel/devtodo/Makefile3
-rw-r--r--devel/patch/Makefile3
-rw-r--r--devel/prcs/Makefile4
-rw-r--r--devel/tdl/Makefile4
5 files changed, 13 insertions, 6 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index e1e8b903fbe8..85cba8dfb589 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -27,6 +27,7 @@ DOCDIR= share/doc/${PORTNAME}
DOCS= ChangeLog LICENSE README
EXAMPLES= cvsgraphwrapper.php3 mkimage.php3
PLIST= ${WRKDIR}/pkg-plist
+USE_REINPLACE= yes
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-freetype2-inc=${X11BASE}/include/freetype2/freetype \
@@ -46,11 +47,11 @@ CONFIGURE_ARGS= --with-freetype2-inc=${X11BASE}/include/freetype2/freetype \
--with-z
pre-patch:
- ${PERL} -pi -e "s:/home/bertho/tmp/cvstest:/home/ncvs:g" \
+ ${REINPLACE_CMD} -e "s:/home/bertho/tmp/cvstest:/home/ncvs:g" \
${WRKSRC}/cvsgraph.conf
post-configure:
- ${PERL} -pi -e \
+ ${REINPLACE_CMD} -e \
"s|CFLAGS =|CFLAGS += -I${LOCALBASE}/include \
-I${LOCALBASE}/include/gd|g" \
${WRKSRC}/Makefile
diff --git a/devel/devtodo/Makefile b/devel/devtodo/Makefile
index a936432f519f..bf78918804fe 100644
--- a/devel/devtodo/Makefile
+++ b/devel/devtodo/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://devtodo.sourceforge.net/?${PORTVERSION}/
MAINTAINER= petef@FreeBSD.org
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
# Note: without this define util/regex.c doesn't compile due to redeclaration
# of malloc and realloc functions. Adding this define was the simplest
@@ -25,7 +26,7 @@ MLINKS= devtodo.1 tda.1 devtodo.1 tdd.1 devtodo.1 tde.1 devtodo.1 tdr.1 \
MANCOMPRESSED= yes
post-patch:
- @${PERL} -pi -e 's/^\ttest -f.*todorc.*\n//' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's/^\ttest -f.*todorc.*\n//' ${WRKSRC}/doc/Makefile.in
post-install:
@${MKDIR} ${EXAMPLESDIR}
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
index 9e767128f476..7f7a77ff7292 100644
--- a/devel/patch/Makefile
+++ b/devel/patch/Makefile
@@ -15,11 +15,12 @@ MAINTAINER= petef@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g
+USE_REINPLACE= yes
MAN1= gpatch.1
post-patch:
- @${PERL} -pi -e 's!HAVE_SETMODE!HAVE_SETMODE_DISABLE!' \
+ @${REINPLACE_CMD} -e 's!HAVE_SETMODE!HAVE_SETMODE_DISABLE!' \
${WRKSRC}/config.hin
.include <bsd.port.mk>
diff --git a/devel/prcs/Makefile b/devel/prcs/Makefile
index 7b1adc7690dc..83115b36a8b8 100644
--- a/devel/prcs/Makefile
+++ b/devel/prcs/Makefile
@@ -15,6 +15,8 @@ MAINTAINER= sam@inf.enst.fr
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
MAN1= prcs.1
.include <bsd.port.pre.mk>
@@ -27,7 +29,7 @@ PLIST_SUB+= EMACS='@comment '
pre-configure:
.if !exists(${LOCALBASE}/bin/emacs)
- ${PERL} -pi -e "s@^(SUBDIRS = .*) emacs (.*)@\1 \2@" \
+ ${REINPLACE_CMD} -e "s@^(SUBDIRS = .*) emacs (.*)@\1 \2@" \
${WRKSRC}/Makefile.in
.endif
diff --git a/devel/tdl/Makefile b/devel/tdl/Makefile
index 4d899b8a4726..5cd192671c25 100644
--- a/devel/tdl/Makefile
+++ b/devel/tdl/Makefile
@@ -12,10 +12,12 @@ MASTER_SITES= http://www.rrbcurnow.freeuk.com/tdl/
MAINTAINER= petef@FreeBSD.org
+USE_REINPLACE= yes
+
MAN1= tdl.1
post-patch:
- @${PERL} -pi -e 's,/usr/local,${PREFIX},; s,gcc,${CC},; \
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},; s,gcc,${CC},; \
s,-O2,${CFLAGS},' ${WRKSRC}/Makefile
.include <bsd.port.mk>