aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-21 03:22:13 +0800
committerpav <pav@FreeBSD.org>2006-03-21 03:22:13 +0800
commit7ecbb7ddcffb9b16d13ab2763ee767871265ad64 (patch)
tree27243782b5afe51914db0a131bf9d20256b5c9dc /devel
parentf0cd995fcd8b1670c02963f9383cd5901bff7676 (diff)
downloadfreebsd-ports-gnome-7ecbb7ddcffb9b16d13ab2763ee767871265ad64.tar.gz
freebsd-ports-gnome-7ecbb7ddcffb9b16d13ab2763ee767871265ad64.tar.zst
freebsd-ports-gnome-7ecbb7ddcffb9b16d13ab2763ee767871265ad64.zip
The Voidspace Pythonutils package is a simple way of installing the Voidspace
collection of modules. These are currently: ConfigObj 4.1.0 - Easy config file reading/writing validate 0.2.1 - Validation and type conversion system listquote 1.4.0 - String to list conversion StandOut 2.1.0 - Simple logging and output control object pathutils 0.2.4 - For working with paths and files cgiutils 0.3.5 - CGI helpers urlpath 0.1.0 - Functions for handling URLs odict 0.2.1 - Ordered Dictionary Class Several of the Voidspace Projects depend on these modules. They are also useful in their own right of course. They are primarily general utility modules that simplify common programming tasks in Python. WWW: http://www.voidspace.org.uk/python/pythonutils.html PR: ports/94657 Submitted by: Daniel <daniel@netwalk.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-utils/Makefile29
-rw-r--r--devel/py-utils/distinfo3
-rw-r--r--devel/py-utils/pkg-descr17
-rw-r--r--devel/py-utils/pkg-plist65
5 files changed, 115 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3ce2d3b39104..b81abeba7802 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1481,6 +1481,7 @@
SUBDIR += py-ui
SUBDIR += py-unit
SUBDIR += py-urwid
+ SUBDIR += py-utils
SUBDIR += py-vmaps
SUBDIR += py-xdg
SUBDIR += py-xoltar-toolkit
diff --git a/devel/py-utils/Makefile b/devel/py-utils/Makefile
new file mode 100644
index 000000000000..7d6bd0a132af
--- /dev/null
+++ b/devel/py-utils/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-utils
+# Date created: 16 March 2006
+# Whom: Daniel Bretoi
+#
+# $FreeBSD$
+#
+
+PORTNAME= utils
+PORTVERSION= 0.2.5
+CATEGORIES= devel
+MASTER_SITES= http://www.voidspace.org.uk/cgi-bin/voidspace/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= downman.py?file=pythonutils-${PORTVERSION}
+
+MAINTAINER= daniel@netwalk.org
+COMMENT= General utility modules that simplify common programming in Python
+
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS=yes
+WRKSRC= ${WRKDIR}/pythonutils-${PORTVERSION}
+USE_ZIP= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-utils/distinfo b/devel/py-utils/distinfo
new file mode 100644
index 000000000000..7fb222b5eace
--- /dev/null
+++ b/devel/py-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (downman.py?file=pythonutils-0.2.5.zip) = 9193f93635e0272a22e651b09d4e278a
+SHA256 (downman.py?file=pythonutils-0.2.5.zip) = 634fb79e2d9c60a5fe9612900cf1e7dae4864c5197f3b436530aa31e770b6778
+SIZE (downman.py?file=pythonutils-0.2.5.zip) = 293531
diff --git a/devel/py-utils/pkg-descr b/devel/py-utils/pkg-descr
new file mode 100644
index 000000000000..4f35f382c2d5
--- /dev/null
+++ b/devel/py-utils/pkg-descr
@@ -0,0 +1,17 @@
+The Voidspace Pythonutils package is a simple way of installing the Voidspace
+collection of modules. These are currently:
+
+ ConfigObj 4.1.0 - Easy config file reading/writing
+ validate 0.2.1 - Validation and type conversion system
+ listquote 1.4.0 - String to list conversion
+ StandOut 2.1.0 - Simple logging and output control object
+ pathutils 0.2.4 - For working with paths and files
+ cgiutils 0.3.5 - CGI helpers
+ urlpath 0.1.0 - Functions for handling URLs
+ odict 0.2.1 - Ordered Dictionary Class
+
+Several of the Voidspace Projects depend on these modules. They are also useful
+in their own right of course. They are primarily general utility modules that
+simplify common programming tasks in Python.
+
+WWW: http://www.voidspace.org.uk/python/pythonutils.html
diff --git a/devel/py-utils/pkg-plist b/devel/py-utils/pkg-plist
new file mode 100644
index 000000000000..0e3cbfb80339
--- /dev/null
+++ b/devel/py-utils/pkg-plist
@@ -0,0 +1,65 @@
+%%PYTHON_SITELIBDIR%%/pythonutils/__init__.py
+%%PYTHON_SITELIBDIR%%/pythonutils/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/cgiutils.py
+%%PYTHON_SITELIBDIR%%/pythonutils/cgiutils.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/cgiutils.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/configobj.py
+%%PYTHON_SITELIBDIR%%/pythonutils/configobj.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/configobj.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/listquote.py
+%%PYTHON_SITELIBDIR%%/pythonutils/listquote.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/listquote.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/odict.py
+%%PYTHON_SITELIBDIR%%/pythonutils/odict.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/odict.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/pathutils.py
+%%PYTHON_SITELIBDIR%%/pythonutils/pathutils.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/pathutils.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/standout.py
+%%PYTHON_SITELIBDIR%%/pythonutils/standout.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/standout.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/urlpath.py
+%%PYTHON_SITELIBDIR%%/pythonutils/urlpath.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/urlpath.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils/validate.py
+%%PYTHON_SITELIBDIR%%/pythonutils/validate.pyc
+%%PYTHON_SITELIBDIR%%/pythonutils/validate.pyo
+%%PYTHON_SITELIBDIR%%/pythonutils.pth
+%%PORTDOCS%%%%DOCSDIR%%/BSD-LICENSE.html
+%%PORTDOCS%%%%DOCSDIR%%/BSD-LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/cgiutils.html
+%%PORTDOCS%%%%DOCSDIR%%/cgiutils.txt
+%%PORTDOCS%%%%DOCSDIR%%/configobj.html
+%%PORTDOCS%%%%DOCSDIR%%/configobj.txt
+%%PORTDOCS%%%%DOCSDIR%%/images/osi-certified-120x100.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/powered_by_python.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/PythonPowered.png
+%%PORTDOCS%%%%DOCSDIR%%/listquote.html
+%%PORTDOCS%%%%DOCSDIR%%/listquote.txt
+%%PORTDOCS%%%%DOCSDIR%%/odict.html
+%%PORTDOCS%%%%DOCSDIR%%/odict.txt
+%%PORTDOCS%%%%DOCSDIR%%/pathutils.html
+%%PORTDOCS%%%%DOCSDIR%%/pathutils.txt
+%%PORTDOCS%%%%DOCSDIR%%/pythonutils.html
+%%PORTDOCS%%%%DOCSDIR%%/pythonutils.txt
+%%PORTDOCS%%%%DOCSDIR%%/smilies/biggrin.gif
+%%PORTDOCS%%%%DOCSDIR%%/smilies/cool.gif
+%%PORTDOCS%%%%DOCSDIR%%/smilies/exclaim.gif
+%%PORTDOCS%%%%DOCSDIR%%/smilies/sad.gif
+%%PORTDOCS%%%%DOCSDIR%%/smilies/smile.gif
+%%PORTDOCS%%%%DOCSDIR%%/smilies/wink.gif
+%%PORTDOCS%%%%DOCSDIR%%/standout.html
+%%PORTDOCS%%%%DOCSDIR%%/standout.txt
+%%PORTDOCS%%%%DOCSDIR%%/stylesheets/default.css
+%%PORTDOCS%%%%DOCSDIR%%/stylesheets/pysrc.css
+%%PORTDOCS%%%%DOCSDIR%%/stylesheets/voidspace_docutils.css
+%%PORTDOCS%%%%DOCSDIR%%/urlpath.html
+%%PORTDOCS%%%%DOCSDIR%%/urlpath.txt
+%%PORTDOCS%%%%DOCSDIR%%/validate.html
+%%PORTDOCS%%%%DOCSDIR%%/validate.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/smilies
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/stylesheets
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/
+@dirrm %%PYTHON_SITELIBDIR%%/pythonutils