aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortegge <tegge@FreeBSD.org>2003-03-27 09:29:24 +0800
committertegge <tegge@FreeBSD.org>2003-03-27 09:29:24 +0800
commit8420b1f4cf7647b40e46eef07630b46573ed9629 (patch)
tree799d6769a49cf0ebdbddb0d40c4309fcd43734e4 /devel
parentd8ed681d363d4c42c12412c7ce0b148ad81fd60d (diff)
downloadfreebsd-ports-gnome-8420b1f4cf7647b40e46eef07630b46573ed9629.tar.gz
freebsd-ports-gnome-8420b1f4cf7647b40e46eef07630b46573ed9629.tar.zst
freebsd-ports-gnome-8420b1f4cf7647b40e46eef07630b46573ed9629.zip
Add _spinunlock() to keep up with libc change in 5.0-CURRENT.
Diffstat (limited to 'devel')
-rw-r--r--devel/linuxthreads/Makefile2
-rw-r--r--devel/linuxthreads/files/libc_thread.c6
2 files changed, 7 insertions, 1 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 72a50bf863c7..ff55a6e57b3e 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxthreads
PORTVERSION= 2.2.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
diff --git a/devel/linuxthreads/files/libc_thread.c b/devel/linuxthreads/files/libc_thread.c
index b58de1990a91..ada205fd2858 100644
--- a/devel/linuxthreads/files/libc_thread.c
+++ b/devel/linuxthreads/files/libc_thread.c
@@ -102,6 +102,12 @@ void _spinlock (int * spinlock)
__pthread_acquire(spinlock);
}
+
+void _spinunlock(int *spinlock)
+{
+ *spinlock = 0;
+}
+
void * lock_create (void *context)
{
pthread_rwlock_t *lock;