aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2014-12-29 12:40:18 +0800
committerkuriyama <kuriyama@FreeBSD.org>2014-12-29 12:40:18 +0800
commit84b9935ab273077a3218e261b350e5405bef4a87 (patch)
tree679be962d84ef7f479e96bda1f863b1b74f16cb2 /devel
parent0fc705d672ecd64315195a637292e899133f7eae (diff)
downloadfreebsd-ports-gnome-84b9935ab273077a3218e261b350e5405bef4a87.tar.gz
freebsd-ports-gnome-84b9935ab273077a3218e261b350e5405bef4a87.tar.zst
freebsd-ports-gnome-84b9935ab273077a3218e261b350e5405bef4a87.zip
The uuid package generates and inspects UUIDs based on RFC 4122 and
DCE 1.1: Authentication and Security Services. WWW: https://code.google.com/p/go-uuid/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-uuid/Makefile23
-rw-r--r--devel/go-uuid/distinfo2
-rw-r--r--devel/go-uuid/pkg-descr4
-rw-r--r--devel/go-uuid/pkg-plist15
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 688b6dcec1e9..6426ad39b48a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -588,6 +588,7 @@
SUBDIR += go-runewidth
SUBDIR += go-sql-driver
SUBDIR += go-termbox
+ SUBDIR += go-uuid
SUBDIR += gob2
SUBDIR += gobject-introspection
SUBDIR += goffice
diff --git a/devel/go-uuid/Makefile b/devel/go-uuid/Makefile
new file mode 100644
index 000000000000..c9d5207f4df3
--- /dev/null
+++ b/devel/go-uuid/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= uuid
+PORTVERSION= 0.0.0.20141202
+CATEGORIES= devel
+MASTER_SITES= LOCAL/kuriyama
+PKGNAMEPREFIX= go-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${REVISION}
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Go library to generates and inspects UUIDs based on RFC 4122
+
+LICENSE= MIT
+
+REVISION= 35bc42037350
+PROJECTHOST= ${PKGNAMEPREFIX}${PORTNAME}
+WRKSRC= ${WRKDIR}/go-uuid-${REVISION}
+GO_PKGNAME= code.google.com/p/go-uuid/uuid
+GO_TARGET= code.google.com/p/go-uuid/uuid/uuid
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-uuid/distinfo b/devel/go-uuid/distinfo
new file mode 100644
index 000000000000..71c7c84b14f1
--- /dev/null
+++ b/devel/go-uuid/distinfo
@@ -0,0 +1,2 @@
+SHA256 (go-uuid-35bc42037350.tar.gz) = ab8936a28a24975f77dd3cb02f5d4dfbc668f69a31287072a700cb607ff75021
+SIZE (go-uuid-35bc42037350.tar.gz) = 41463
diff --git a/devel/go-uuid/pkg-descr b/devel/go-uuid/pkg-descr
new file mode 100644
index 000000000000..40c646466720
--- /dev/null
+++ b/devel/go-uuid/pkg-descr
@@ -0,0 +1,4 @@
+The uuid package generates and inspects UUIDs based on RFC 4122 and
+DCE 1.1: Authentication and Security Services.
+
+WWW: https://code.google.com/p/go-uuid/
diff --git a/devel/go-uuid/pkg-plist b/devel/go-uuid/pkg-plist
new file mode 100644
index 000000000000..8c8f717dc885
--- /dev/null
+++ b/devel/go-uuid/pkg-plist
@@ -0,0 +1,15 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/uuid.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/dce.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/doc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/hash.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/json.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/json_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/node.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/seq_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/time.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/util.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/uuid.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/uuid_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/version1.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uuid/version4.go