aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-06-10 18:46:06 +0800
committererwin <erwin@FreeBSD.org>2006-06-10 18:46:06 +0800
commit8753e088260328e78070b2689d92f1165b6b7279 (patch)
treee810ff682a433b4fea992ca941a5176ec4e3ccd3 /devel
parentf40a8ebd26fee0984834b692c1201ef25403f5b9 (diff)
downloadfreebsd-ports-gnome-8753e088260328e78070b2689d92f1165b6b7279.tar.gz
freebsd-ports-gnome-8753e088260328e78070b2689d92f1165b6b7279.tar.zst
freebsd-ports-gnome-8753e088260328e78070b2689d92f1165b6b7279.zip
The Rose::DateTime::* modules provide a few convenience functions
and objects for use with DateTime dates. WWW: http://search.cpan.org/dist/Rose-DateTime/ PR: ports/98767 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Rose-DateTime/Makefile34
-rw-r--r--devel/p5-Rose-DateTime/distinfo3
-rw-r--r--devel/p5-Rose-DateTime/pkg-descr4
-rw-r--r--devel/p5-Rose-DateTime/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a7049f0c3d21..7a4b93a98e43 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1201,6 +1201,7 @@
SUBDIR += p5-ResourcePool
SUBDIR += p5-Resources
SUBDIR += p5-Return-Value
+ SUBDIR += p5-Rose-DateTime
SUBDIR += p5-Rose-Object
SUBDIR += p5-SDL
SUBDIR += p5-SPOPS
diff --git a/devel/p5-Rose-DateTime/Makefile b/devel/p5-Rose-DateTime/Makefile
new file mode 100644
index 000000000000..e6a66f5979e6
--- /dev/null
+++ b/devel/p5-Rose-DateTime/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: devel/p5-Rose-DateTime
+# Date created: 09 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Rose-DateTime
+PORTVERSION= 0.522
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Rose
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= DateTime helper functions and objects
+
+BUILD_DEPENDS= ${SITE_PERL}/Rose/Object.pm:${PORTSDIR}/devel/p5-Rose-Object \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Rose::DateTime.3 \
+ Rose::DateTime::Parser.3 \
+ Rose::DateTime::Util.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Rose-DateTime/distinfo b/devel/p5-Rose-DateTime/distinfo
new file mode 100644
index 000000000000..64a31dfd7148
--- /dev/null
+++ b/devel/p5-Rose-DateTime/distinfo
@@ -0,0 +1,3 @@
+MD5 (Rose-DateTime-0.522.tar.gz) = e8851302933f0f74178d7fa85d9654fb
+SHA256 (Rose-DateTime-0.522.tar.gz) = a285667854ce5d9070cc7bc56ad28bad6c146674b6bc7c10265a0402cf06d047
+SIZE (Rose-DateTime-0.522.tar.gz) = 11395
diff --git a/devel/p5-Rose-DateTime/pkg-descr b/devel/p5-Rose-DateTime/pkg-descr
new file mode 100644
index 000000000000..e03c828b1e4c
--- /dev/null
+++ b/devel/p5-Rose-DateTime/pkg-descr
@@ -0,0 +1,4 @@
+The Rose::DateTime::* modules provide a few convenience functions
+and objects for use with DateTime dates.
+
+WWW: http://search.cpan.org/dist/Rose-DateTime/
diff --git a/devel/p5-Rose-DateTime/pkg-plist b/devel/p5-Rose-DateTime/pkg-plist
new file mode 100644
index 000000000000..ab4b40a55aa2
--- /dev/null
+++ b/devel/p5-Rose-DateTime/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Rose/DateTime.pm
+%%SITE_PERL%%/Rose/DateTime/Parser.pm
+%%SITE_PERL%%/Rose/DateTime/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose/DateTime/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose/DateTime
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose
+@dirrmtry %%SITE_PERL%%/Rose/DateTime
+@dirrmtry %%SITE_PERL%%/Rose