aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-10-03 15:30:46 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-10-03 15:30:46 +0800
commit89593b8e82c40908c51c435223b67ba373e09999 (patch)
tree7e7dc1d3eb44eba47f0527d53a2004e67a08dcd4 /devel
parenta6468512ebbb7f46456266e0207c2ce0c6d51678 (diff)
downloadfreebsd-ports-gnome-89593b8e82c40908c51c435223b67ba373e09999.tar.gz
freebsd-ports-gnome-89593b8e82c40908c51c435223b67ba373e09999.tar.zst
freebsd-ports-gnome-89593b8e82c40908c51c435223b67ba373e09999.zip
Add cl-port-clisp 2002.10.02.1, cross-Lisp portability package.
CLOCC Port provides a portable interface to various features absent from the ANSI Common Lisp standard, such as sockets, multiprocessing, calling external programs, Gray streams etc. PR: 52368 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cl-port-clisp/Makefile40
-rw-r--r--devel/cl-port-clisp/pkg-descr10
-rw-r--r--devel/cl-port-clisp/pkg-plist8
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 79b4b89d4827..bcfa1069e884 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -106,6 +106,7 @@
SUBDIR += cl-asdf-cmucl
SUBDIR += cl-asdf-sbcl
SUBDIR += cl-port
+ SUBDIR += cl-port-clisp
SUBDIR += cl-port-cmucl
SUBDIR += cl-port-sbcl
SUBDIR += cl-split-sequence
diff --git a/devel/cl-port-clisp/Makefile b/devel/cl-port-clisp/Makefile
new file mode 100644
index 000000000000..882d8c3893a4
--- /dev/null
+++ b/devel/cl-port-clisp/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: cl-port-clisp
+# Date created: 12 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= port
+PORTVERSION= 2002.10.02.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ ftp://www.aarg.net/pub/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -clisp
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= Cross-Lisp portability package
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
+ clisp:${PORTSDIR}/lang/clisp
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
+ clisp:${PORTSDIR}/lang/clisp
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ clisp -q -ansi -norc \
+ -i ${LOCALBASE}/etc/asdf-init \
+ -x "(asdf:oos 'asdf:compile-op :port)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/port/clispfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/port/clispfasl/
+
+.include <bsd.port.mk>
diff --git a/devel/cl-port-clisp/pkg-descr b/devel/cl-port-clisp/pkg-descr
new file mode 100644
index 000000000000..16d2f2173d74
--- /dev/null
+++ b/devel/cl-port-clisp/pkg-descr
@@ -0,0 +1,10 @@
+CLOCC Port provides a portable interface to various features absent
+from the ANSI Common Lisp standard, such as sockets, multiprocessing,
+calling external programs, Gray streams etc.
+
+This package contains binaries compiled for CLISP.
+
+WWW: http://clocc.sourceforge.net
+
+-- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/devel/cl-port-clisp/pkg-plist b/devel/cl-port-clisp/pkg-plist
new file mode 100644
index 000000000000..8d2eaee66dd2
--- /dev/null
+++ b/devel/cl-port-clisp/pkg-plist
@@ -0,0 +1,8 @@
+lib/common-lisp/port/clispfasl/ext.fasl
+lib/common-lisp/port/clispfasl/gray.fasl
+lib/common-lisp/port/clispfasl/net.fasl
+lib/common-lisp/port/clispfasl/path.fasl
+lib/common-lisp/port/clispfasl/proc.fasl
+lib/common-lisp/port/clispfasl/shell.fasl
+lib/common-lisp/port/clispfasl/sys.fasl
+@dirrm lib/common-lisp/port/clispfasl