aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-05-05 03:52:34 +0800
committerstas <stas@FreeBSD.org>2009-05-05 03:52:34 +0800
commit89cb0db7f9fc982ec04075de47d505c99611adaf (patch)
tree8ec49dcf35b5110b7fe16ec36a999fc48dd2b54d /devel
parente1508a9d51fa5b729e3ea5975e56111a074ef6a5 (diff)
downloadfreebsd-ports-gnome-89cb0db7f9fc982ec04075de47d505c99611adaf.tar.gz
freebsd-ports-gnome-89cb0db7f9fc982ec04075de47d505c99611adaf.tar.zst
freebsd-ports-gnome-89cb0db7f9fc982ec04075de47d505c99611adaf.zip
- Fix libftdi on HEAD by including stdlib.h in ftdi.c. Since HEAD's
version on usb.h doesn't include stdlib.h like libusb does, it fails to find prototypes for realloc function which leads to incorrect storage types used and memory corruption as a consequence.
Diffstat (limited to 'devel')
-rw-r--r--devel/libftdi/Makefile1
-rw-r--r--devel/libftdi/files/patch-src_ftdi.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
index 76f9b4d0fe3f..3c59be202987 100644
--- a/devel/libftdi/Makefile
+++ b/devel/libftdi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libftdi
PORTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.intra2net.com/de/produkte/opensource/ftdi/TGZ/
diff --git a/devel/libftdi/files/patch-src_ftdi.c b/devel/libftdi/files/patch-src_ftdi.c
new file mode 100644
index 000000000000..9a6079fd7cfe
--- /dev/null
+++ b/devel/libftdi/files/patch-src_ftdi.c
@@ -0,0 +1,10 @@
+--- src/ftdi.c.orig 2009-05-04 23:37:26.000000000 +0400
++++ src/ftdi.c 2009-05-04 23:37:46.000000000 +0400
+@@ -28,6 +28,7 @@
+ /** \addtogroup libftdi */
+ /* @{ */
+
++#include <stdlib.h>
+ #include <usb.h>
+ #include <string.h>
+ #include <errno.h>