aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2018-11-03 20:34:51 +0800
committerbsam <bsam@FreeBSD.org>2018-11-03 20:34:51 +0800
commit8f219ea5f89d0ee5e1f834d3d9aad5b5fca29b50 (patch)
treeb68aa8a114bc7b797cd091b8b2d75ab8759e93c5 /devel
parent9a87c1dddcfacfb0ba879cca25da144242a4a3ee (diff)
downloadfreebsd-ports-gnome-8f219ea5f89d0ee5e1f834d3d9aad5b5fca29b50.tar.gz
freebsd-ports-gnome-8f219ea5f89d0ee5e1f834d3d9aad5b5fca29b50.tar.zst
freebsd-ports-gnome-8f219ea5f89d0ee5e1f834d3d9aad5b5fca29b50.zip
devel/libsigrok: Update to version 0.5.1
This is a "minor" release that doesn't change or remove any existing public API functions, so all existing clients will continue to work (without even the need to recompile). The following hardware is now (additionally) supported: * Logic analyzers: DreamSourceLab DSLogic Basic/Plus, Hantek 4032L, IPDBG (ipdbg.org FPGA IP debugger), Meilhaus Logian-16L, Saleae Logic Pro 16, ZEROPLUS Logic Cube LAP-C (16128+) / LAP-16032U * Oscilloscopes: Agilent MSO7034A, Hantek DSO-2250, Rigol DS4000 series, Siglent SDS1000/SDS2000 series * Programmable power supplies: GW Instek GPD series, HP 6631B/66332A/6633B/6634B, Korad KD3005P, RDTech DPS/DPH series, Rigol DP711/DP712, RND KA3005P, Tenma 72-2540 * Electronic loads: ZKETECH EBD-USB * Multimeters: EEVblog 121GW, Fluke 45, HP 3478A, MASTECH MS8250D, Metex M-3860M, PeakTech 4390A, SparkFun 70C, Victor DMMs with Mini-USB connector, Voltcraft VC-96 Pretty much every existing hardware driver has also received numerous fixes and improvements. There have also been quite a few bugfixes, documentation fixes, portability fixes, build system improvements, performance improvements, and so on. There are some new API calls now, you can read up all the details in the API docs. See the NEWS file for a much more detailed list of changes, or browse the git history for even more details.
Diffstat (limited to 'devel')
-rw-r--r--devel/libsigrok/Makefile7
-rw-r--r--devel/libsigrok/distinfo6
-rw-r--r--devel/libsigrok/files/patch-src_hardware_chronovu-la_api.c15
-rw-r--r--devel/libsigrok/files/patch-src_hardware_fx2lafw_api.c15
-rw-r--r--devel/libsigrok/pkg-plist6
5 files changed, 9 insertions, 40 deletions
diff --git a/devel/libsigrok/Makefile b/devel/libsigrok/Makefile
index 04bdcb09da99..1ba89e5464be 100644
--- a/devel/libsigrok/Makefile
+++ b/devel/libsigrok/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libsigrok
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.5.1
CATEGORIES= devel
MASTER_SITES= http://sigrok.org/download/source/libsigrok/
@@ -19,9 +18,9 @@ LIB_DEPENDS= libftdi1.so:devel/libftdi1 \
libvisa.so:devel/librevisa \
libzip.so:archivers/libzip
+USES= gnome pathfix libtool pkgconfig
+
GNU_CONFIGURE= yes
-USES= pathfix libtool pkgconfig
-USE_GNOME= glib20
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
diff --git a/devel/libsigrok/distinfo b/devel/libsigrok/distinfo
index e8969a34b2b3..8191e08e7d4d 100644
--- a/devel/libsigrok/distinfo
+++ b/devel/libsigrok/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507555128
-SHA256 (libsigrok-0.5.0.tar.gz) = 4c8c86779b880a5c419f6c77a08b1147021e5a19fa83b0f3b19da27463c9f3a4
-SIZE (libsigrok-0.5.0.tar.gz) = 1560400
+TIMESTAMP = 1539542675
+SHA256 (libsigrok-0.5.1.tar.gz) = e40fde7af98d29e922e9d3cbe0a6c0569889153fc31e47b8b1afe4d846292b9c
+SIZE (libsigrok-0.5.1.tar.gz) = 1664813
diff --git a/devel/libsigrok/files/patch-src_hardware_chronovu-la_api.c b/devel/libsigrok/files/patch-src_hardware_chronovu-la_api.c
deleted file mode 100644
index cdb9d24f887e..000000000000
--- a/devel/libsigrok/files/patch-src_hardware_chronovu-la_api.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/hardware/chronovu-la/api.c.orig
-+++ src/hardware/chronovu-la/api.c
-@@ -200,10 +200,10 @@
- continue;
- }
-
-- usb_get_port_path(devlist[i], connection_id, sizeof(connection_id));
--
- libusb_close(hdl);
-
-+ usb_get_port_path(devlist[i], connection_id, sizeof(connection_id));
-+
- if (!strcmp(product, "ChronoVu LA8")) {
- model = 0;
- } else if (!strcmp(product, "ChronoVu LA16")) {
diff --git a/devel/libsigrok/files/patch-src_hardware_fx2lafw_api.c b/devel/libsigrok/files/patch-src_hardware_fx2lafw_api.c
deleted file mode 100644
index f48d6624aa54..000000000000
--- a/devel/libsigrok/files/patch-src_hardware_fx2lafw_api.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/hardware/fx2lafw/api.c.orig
-+++ src/hardware/fx2lafw/api.c
-@@ -325,10 +325,10 @@
- continue;
- }
-
-- usb_get_port_path(devlist[i], connection_id, sizeof(connection_id));
--
- libusb_close(hdl);
-
-+ usb_get_port_path(devlist[i], connection_id, sizeof(connection_id));
-+
- prof = NULL;
- for (j = 0; supported_fx2[j].vid; j++) {
- if (des.idVendor == supported_fx2[j].vid &&
diff --git a/devel/libsigrok/pkg-plist b/devel/libsigrok/pkg-plist
index a6f95daa8816..d5853d42c924 100644
--- a/devel/libsigrok/pkg-plist
+++ b/devel/libsigrok/pkg-plist
@@ -6,13 +6,13 @@ include/libsigrokcxx/libsigrokcxx.hpp
lib/libsigrok.a
lib/libsigrok.so
lib/libsigrok.so.4
-lib/libsigrok.so.4.0.0
+lib/libsigrok.so.4.1.0
lib/libsigrokcxx.a
lib/libsigrokcxx.so
lib/libsigrokcxx.so.4
-lib/libsigrokcxx.so.4.0.0
+lib/libsigrokcxx.so.4.1.0
libdata/pkgconfig/libsigrok.pc
libdata/pkgconfig/libsigrokcxx.pc
share/icons/hicolor/48x48/mimetypes/libsigrok.png
share/icons/hicolor/scalable/mimetypes/libsigrok.svg
-share/mime/application/vnd.sigrok.session.xml
+share/mime/packages/vnd.sigrok.session.xml