aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-07-01 01:34:39 +0800
committermarcus <marcus@FreeBSD.org>2003-07-01 01:34:39 +0800
commit911650224b20c74e6bc1b366690cc46335d8c70b (patch)
treea4b842adb78a0f8638c792691fc14b22ee33ee56 /devel
parentc359c5da2c41e5b82d66ab8013f775a625599ce7 (diff)
downloadfreebsd-ports-gnome-911650224b20c74e6bc1b366690cc46335d8c70b.tar.gz
freebsd-ports-gnome-911650224b20c74e6bc1b366690cc46335d8c70b.tar.zst
freebsd-ports-gnome-911650224b20c74e6bc1b366690cc46335d8c70b.zip
Make sure we link against ${PTHREAD_LIBS}. This fixes a build problem
on -STABLE, and some runtime threading issues on -CURRENT. PR: 53918 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/devhelp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 172ba45a74be..fe764fa1d902 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -7,9 +7,10 @@
PORTNAME= devhelp
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.7
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
DIST_SUBDIR= gnome2
MAINTAINER= rui@ruilopes.com
@@ -21,7 +22,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgtkhtml libgnomeui
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
.include <bsd.port.mk>