aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-07-10 04:25:53 +0800
committerbeech <beech@FreeBSD.org>2008-07-10 04:25:53 +0800
commit92605d96178b8133822b11b9ef4887664935cb2e (patch)
tree7030748d4593c0cf3fda1853d8af35510a15517d /devel
parent990d24448349543099bd71cb5b84e691a515e919 (diff)
downloadfreebsd-ports-gnome-92605d96178b8133822b11b9ef4887664935cb2e.tar.gz
freebsd-ports-gnome-92605d96178b8133822b11b9ef4887664935cb2e.tar.zst
freebsd-ports-gnome-92605d96178b8133822b11b9ef4887664935cb2e.zip
- New port p5-POE-XS-Loop-Poll-0.004
Implementation of the abstract POE::Loop interface written in C using the poll(2) system call. PR: ports/125377 Submitted by: Zach Thompson <hideo at lastamericanempire.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-XS-Loop-Poll/Makefile25
-rw-r--r--devel/p5-POE-XS-Loop-Poll/distinfo3
-rw-r--r--devel/p5-POE-XS-Loop-Poll/pkg-descr4
-rw-r--r--devel/p5-POE-XS-Loop-Poll/pkg-plist11
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0dc1b24d36e5..c4743930cba3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1512,6 +1512,7 @@
SUBDIR += p5-POE-Session-MultiDispatch
SUBDIR += p5-POE-Stage
SUBDIR += p5-POE-Test-Loops
+ SUBDIR += p5-POE-XS-Loop-Poll
SUBDIR += p5-POE-XS-Queue-Array
SUBDIR += p5-POSIX-strptime
SUBDIR += p5-PPerl
diff --git a/devel/p5-POE-XS-Loop-Poll/Makefile b/devel/p5-POE-XS-Loop-Poll/Makefile
new file mode 100644
index 000000000000..f97f607124fd
--- /dev/null
+++ b/devel/p5-POE-XS-Loop-Poll/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-POE-XS-Loop-Poll
+# Date created: 03 July 2008
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-XS-Loop-Poll
+PORTVERSION= 0.004
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= XS implementation of POE::Loop, using poll(2)
+
+BUILD_DEPENDS= ${SITE_PERL}/POE/Test/Loops.pm:${PORTSDIR}/devel/p5-POE-Test-Loops
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_SCRIPT+= Makefile.PL --default
+
+MAN3= POE::XS::Loop::Poll.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-XS-Loop-Poll/distinfo b/devel/p5-POE-XS-Loop-Poll/distinfo
new file mode 100644
index 000000000000..d886c68e9d4b
--- /dev/null
+++ b/devel/p5-POE-XS-Loop-Poll/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-XS-Loop-Poll-0.004.tar.gz) = d5bd466f1db98f0e937043d96d9568d9
+SHA256 (POE-XS-Loop-Poll-0.004.tar.gz) = 844b454b5fb4cdc9f22aaae03de899e3df8237625104a18d9e07b4404f496bbc
+SIZE (POE-XS-Loop-Poll-0.004.tar.gz) = 10299
diff --git a/devel/p5-POE-XS-Loop-Poll/pkg-descr b/devel/p5-POE-XS-Loop-Poll/pkg-descr
new file mode 100644
index 000000000000..bc394168bb1f
--- /dev/null
+++ b/devel/p5-POE-XS-Loop-Poll/pkg-descr
@@ -0,0 +1,4 @@
+Implementation of the abstract POE::Loop interface written in C
+using the poll(2) system call.
+
+WWW: http://search.cpan.org/dist/POE-XS-Loop-Poll/
diff --git a/devel/p5-POE-XS-Loop-Poll/pkg-plist b/devel/p5-POE-XS-Loop-Poll/pkg-plist
new file mode 100644
index 000000000000..e1f69175d204
--- /dev/null
+++ b/devel/p5-POE-XS-Loop-Poll/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/POE/XS/Loop/Poll.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Loop/Poll/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Loop/Poll/Poll.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Loop/Poll/Poll.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Loop/Poll
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Loop
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE/XS/Loop
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE