aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-01-18 08:50:46 +0800
committerclsung <clsung@FreeBSD.org>2006-01-18 08:50:46 +0800
commit948518c09360ca17a98f395c30f96cf05f122fff (patch)
tree6c77352dc16a025fb08cab6aa364207fd1eece93 /devel
parentfd31dc85c2e5638b05703d4951708483ee7719a7 (diff)
downloadfreebsd-ports-gnome-948518c09360ca17a98f395c30f96cf05f122fff.tar.gz
freebsd-ports-gnome-948518c09360ca17a98f395c30f96cf05f122fff.tar.zst
freebsd-ports-gnome-948518c09360ca17a98f395c30f96cf05f122fff.zip
- add p5-SVN-ACL
- ref: http://hcchien.org/?q=node/7
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-ACL/Makefile28
-rw-r--r--devel/p5-SVN-ACL/distinfo3
-rw-r--r--devel/p5-SVN-ACL/pkg-descr9
-rw-r--r--devel/p5-SVN-ACL/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0506c8fca031..d75475b6da14 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1115,6 +1115,7 @@
SUBDIR += p5-Return-Value
SUBDIR += p5-SDL
SUBDIR += p5-SPOPS
+ SUBDIR += p5-SVN-ACL
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
SUBDIR += p5-SVN-Simple
diff --git a/devel/p5-SVN-ACL/Makefile b/devel/p5-SVN-ACL/Makefile
new file mode 100644
index 000000000000..c359b643099f
--- /dev/null
+++ b/devel/p5-SVN-ACL/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-SVN-ACL
+# Date created: Jan 2006
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-ACL
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A simple ACL frontend for subversion
+
+BUILD_DEPENDS= \
+ subversion-perl>=1.3.0:${PORTSDIR}/devel/subversion-perl \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::ACL.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-ACL/distinfo b/devel/p5-SVN-ACL/distinfo
new file mode 100644
index 000000000000..9ba1b25cf218
--- /dev/null
+++ b/devel/p5-SVN-ACL/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-ACL-0.02.tgz) = bcc74185dc21b6db39518cfd94b67849
+SHA256 (SVN-ACL-0.02.tgz) = 410e2ff78376419e78ddc5099540bf99311250c9828b8b189ea59d47baf96461
+SIZE (SVN-ACL-0.02.tgz) = 10311
diff --git a/devel/p5-SVN-ACL/pkg-descr b/devel/p5-SVN-ACL/pkg-descr
new file mode 100644
index 000000000000..f3f05abf781a
--- /dev/null
+++ b/devel/p5-SVN-ACL/pkg-descr
@@ -0,0 +1,9 @@
+SVN::ACL is a simple fronend to make the svnserve.conf, passwd,
+authz for Subversion.
+
+After subversion 1.3.0, it offers the new access control for
+using the svnserve. When you use svnadmin to create a new
+subversion repository. The svnserve.conf, passwd and authz will
+be generated by subversion automatically.
+
+WWW: http://search.cpan.org/dist/SVN-ACL/
diff --git a/devel/p5-SVN-ACL/pkg-plist b/devel/p5-SVN-ACL/pkg-plist
new file mode 100644
index 000000000000..f6e98ea2a541
--- /dev/null
+++ b/devel/p5-SVN-ACL/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SVN/ACL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/ACL/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/ACL
+@unexec rmdir %D/%%SITE_PERL%%/SVN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN 2>/dev/null || true