aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-27 08:18:49 +0800
committermarcus <marcus@FreeBSD.org>2004-07-27 08:18:49 +0800
commit960d921603daef5e25db9b320c26e6a776fcb8a8 (patch)
treed22f29041134068f06f015c8860651a7e909b27f /devel
parentd768cfa1e8a1fdefc6ec8ab23d96cf36cb1f8be5 (diff)
downloadfreebsd-ports-gnome-960d921603daef5e25db9b320c26e6a776fcb8a8.tar.gz
freebsd-ports-gnome-960d921603daef5e25db9b320c26e6a776fcb8a8.tar.zst
freebsd-ports-gnome-960d921603daef5e25db9b320c26e6a776fcb8a8.zip
Add py-dbus, Python bindings for the D-BUS messaging system.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-dbus/Makefile41
-rw-r--r--devel/py-dbus/pkg-descr3
-rw-r--r--devel/py-dbus/pkg-plist4
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cac842cac57a..fb4eb3c00f0e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1104,6 +1104,7 @@
SUBDIR += py-ctypes
SUBDIR += py-cxx
SUBDIR += py-dialog
+ SUBDIR += py-dbus
SUBDIR += py-fam
SUBDIR += py-fileutils
SUBDIR += py-fortran
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
new file mode 100644
index 000000000000..a3bcd2f6142d
--- /dev/null
+++ b/devel/py-dbus/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-dbus
+# Date Created: 25 July 2004
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface to the D-BUS messaging system
+
+LIB_DEPENDS= dbus-1.0:${PORTSDIR}/devel/dbus
+RUN_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../dbus
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+DBUS_SLAVE= yes
+
+USE_GNOME= gnomehack gnometarget
+USE_PYTHON= yes
+CONFIGURE_ARGS= --enable-python \
+ --disable-gcj \
+ --disable-mono \
+ --disable-gtk \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus \
+ --with-session-socket-dir=/var/tmp \
+ --disable-doxygen-docs \
+ --disable-xml-docs
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-dbus/pkg-descr b/devel/py-dbus/pkg-descr
new file mode 100644
index 000000000000..059c9a3ed457
--- /dev/null
+++ b/devel/py-dbus/pkg-descr
@@ -0,0 +1,3 @@
+Python interface to the D-BUS messaging system.
+
+WWW: http://www.freedesktop.org/Software/dbus
diff --git a/devel/py-dbus/pkg-plist b/devel/py-dbus/pkg-plist
new file mode 100644
index 000000000000..0b654b1fe25c
--- /dev/null
+++ b/devel/py-dbus/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/dbus.py
+lib/%%PYTHON_VERSION%%/site-packages/dbus.pyc
+lib/%%PYTHON_VERSION%%/site-packages/dbus.pyo
+lib/%%PYTHON_VERSION%%/site-packages/dbus_bindings.so