aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2017-09-27 12:06:14 +0800
committervanilla <vanilla@FreeBSD.org>2017-09-27 12:06:14 +0800
commit98fb12a27b613c4ec7a1d51a034d3781c4171e44 (patch)
tree9905afe9cc9a098d7765df1376b1488c0a5983af /devel
parent9f6bd42793b03e2c87b15797bf8417a07c2a3200 (diff)
downloadfreebsd-ports-gnome-98fb12a27b613c4ec7a1d51a034d3781c4171e44.tar.gz
freebsd-ports-gnome-98fb12a27b613c4ec7a1d51a034d3781c4171e44.tar.zst
freebsd-ports-gnome-98fb12a27b613c4ec7a1d51a034d3781c4171e44.zip
1: Update to 1.9.21
2: add a patch for libressl.
Diffstat (limited to 'devel')
-rw-r--r--devel/pecl-swoole/Makefile6
-rw-r--r--devel/pecl-swoole/distinfo6
-rw-r--r--devel/pecl-swoole/files/patch-config.m44
-rw-r--r--devel/pecl-swoole/files/patch-src_protocol_SSL.c11
4 files changed, 18 insertions, 9 deletions
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index b1867d055e29..2a2627a7a34d 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= swoole
-PORTVERSION= 1.9.16
+PORTVERSION= 1.9.21
CATEGORIES= devel net
MAINTAINER= vanilla@FreeBSD.org
@@ -18,13 +18,11 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_PHP= pcre
-OPTIONS_DEFINE= HTTP2 REDIS RING_BUFFER SOCKETS
+OPTIONS_DEFINE= HTTP2 REDIS SOCKETS
HTTP2_LIB_DEPENDS= libnghttp2.so:www/libnghttp2
HTTP2_CONFIGURE_ON= --enable-http2 --enable-openssl
REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
REDIS_CONFIGURE_ON= --enable-async-redis
-RING_BUFFER_DESC= Use ring buffer pool
-RING_BUFFER_CONFIGURE_ON= --enable-ringbuffer
SOCKETS_USE= PHP=sockets:build
SOCKETS_DESC= Use native php sockets extension
SOCKETS_CONFIGURE_ON= --enable-sockets
diff --git a/devel/pecl-swoole/distinfo b/devel/pecl-swoole/distinfo
index f1ac571c7011..e6cc7d0560ad 100644
--- a/devel/pecl-swoole/distinfo
+++ b/devel/pecl-swoole/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500129219
-SHA256 (PECL/swoole-1.9.16.tgz) = bd7a13b2ab5663cb28af24945246b2bcf280b667686548e1314778a72dcabab2
-SIZE (PECL/swoole-1.9.16.tgz) = 689633
+TIMESTAMP = 1506483954
+SHA256 (PECL/swoole-1.9.21.tgz) = 4e8dbd491693c2cc34e8af657f759ca661db3a25860f96242f6c62db8008b70b
+SIZE (PECL/swoole-1.9.21.tgz) = 707603
diff --git a/devel/pecl-swoole/files/patch-config.m4 b/devel/pecl-swoole/files/patch-config.m4
index 246bbb256e80..a4e0f8739ca0 100644
--- a/devel/pecl-swoole/files/patch-config.m4
+++ b/devel/pecl-swoole/files/patch-config.m4
@@ -1,6 +1,6 @@
---- config.m4.orig 2017-04-18 09:30:04 UTC
+--- config.m4.orig 2017-09-26 08:30:45 UTC
+++ config.m4
-@@ -250,7 +250,7 @@ if test "$PHP_SWOOLE" != "no"; then
+@@ -255,7 +255,7 @@ if test "$PHP_SWOOLE" != "no"; then
AC_CHECK_LIB(c, poll, AC_DEFINE(HAVE_POLL, 1, [have poll]))
AC_CHECK_LIB(c, sendfile, AC_DEFINE(HAVE_SENDFILE, 1, [have sendfile]))
AC_CHECK_LIB(c, kqueue, AC_DEFINE(HAVE_KQUEUE, 1, [have kqueue]))
diff --git a/devel/pecl-swoole/files/patch-src_protocol_SSL.c b/devel/pecl-swoole/files/patch-src_protocol_SSL.c
new file mode 100644
index 000000000000..8c0479d16650
--- /dev/null
+++ b/devel/pecl-swoole/files/patch-src_protocol_SSL.c
@@ -0,0 +1,11 @@
+--- src/protocol/SSL.c.orig 2017-09-27 04:04:44 UTC
++++ src/protocol/SSL.c
+@@ -98,7 +98,7 @@ static const SSL_METHOD *swSSL_get_metho
+
+ void swSSL_init(void)
+ {
+-#if OPENSSL_VERSION_NUMBER >= 0x10100003L && !defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER >= 0x10100003L
+ OPENSSL_init_ssl(OPENSSL_INIT_LOAD_CONFIG, NULL);
+ #else
+ OPENSSL_config(NULL);