aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-10-19 05:27:02 +0800
committerahze <ahze@FreeBSD.org>2005-10-19 05:27:02 +0800
commit9a0a77249bab589e7ff92c90cd46fcb39d649567 (patch)
tree70829f1a922581f28d9dbb24c8703654779c0616 /devel
parent53369662134f0f9c8aac2c808ead15a5c800ff09 (diff)
downloadfreebsd-ports-gnome-9a0a77249bab589e7ff92c90cd46fcb39d649567.tar.gz
freebsd-ports-gnome-9a0a77249bab589e7ff92c90cd46fcb39d649567.tar.zst
freebsd-ports-gnome-9a0a77249bab589e7ff92c90cd46fcb39d649567.zip
- Add devel/libdaemon
Lightweight C library that eases the writing of UNIX daemons WWW: http://0pointer.de/lennart/projects/libdaemon
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libdaemon/Makefile21
-rw-r--r--devel/libdaemon/distinfo2
-rw-r--r--devel/libdaemon/files/patch-libdaemond_dfork.c11
-rw-r--r--devel/libdaemon/pkg-descr3
-rw-r--r--devel/libdaemon/pkg-plist12
6 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 78f445e49fad..ec91f7475945 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -447,6 +447,7 @@
SUBDIR += libconfuse
SUBDIR += libcoro
SUBDIR += libcwd
+ SUBDIR += libdaemon
SUBDIR += libdict
SUBDIR += libdlmalloc
SUBDIR += libds
diff --git a/devel/libdaemon/Makefile b/devel/libdaemon/Makefile
new file mode 100644
index 000000000000..0fab73ad4e23
--- /dev/null
+++ b/devel/libdaemon/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: libdaemon
+# Date created: 2005-10-17
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdaemon
+PORTVERSION= 0.8
+CATEGORIES= devel
+MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Lightweight C library that eases the writing of UNIX daemons
+
+CONFIGURE_ARGS= --disable-lynx
+USE_LIBTOOL_VER=15
+USE_GNOME= gnomehack
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libdaemon/distinfo b/devel/libdaemon/distinfo
new file mode 100644
index 000000000000..1bbda489142c
--- /dev/null
+++ b/devel/libdaemon/distinfo
@@ -0,0 +1,2 @@
+MD5 (libdaemon-0.8.tar.gz) = 49cc7db480c6d7b8ca88b0db8ac275e7
+SIZE (libdaemon-0.8.tar.gz) = 331447
diff --git a/devel/libdaemon/files/patch-libdaemond_dfork.c b/devel/libdaemon/files/patch-libdaemond_dfork.c
new file mode 100644
index 000000000000..2871d27f26db
--- /dev/null
+++ b/devel/libdaemon/files/patch-libdaemond_dfork.c
@@ -0,0 +1,11 @@
+--- libdaemon/dfork.c.orig Mon Oct 17 22:58:04 2005
++++ libdaemon/dfork.c Mon Oct 17 23:11:36 2005
+@@ -209,7 +209,7 @@
+ signal(SIGTSTP, SIG_IGN);
+
+ setsid();
+- setpgrp();
++ setpgrp(0, getpid());
+
+ if ((tty_fd = open("/dev/tty", O_RDWR)) >= 0) {
+ ioctl(tty_fd, TIOCNOTTY, NULL);
diff --git a/devel/libdaemon/pkg-descr b/devel/libdaemon/pkg-descr
new file mode 100644
index 000000000000..125a64a59e65
--- /dev/null
+++ b/devel/libdaemon/pkg-descr
@@ -0,0 +1,3 @@
+Lightweight C library that eases the writing of UNIX daemons
+
+WWW: http://0pointer.de/lennart/projects/libdaemon/
diff --git a/devel/libdaemon/pkg-plist b/devel/libdaemon/pkg-plist
new file mode 100644
index 000000000000..9017ecaa3fae
--- /dev/null
+++ b/devel/libdaemon/pkg-plist
@@ -0,0 +1,12 @@
+include/libdaemon/daemon.h
+include/libdaemon/dexec.h
+include/libdaemon/dfork.h
+include/libdaemon/dlog.h
+include/libdaemon/dnonblock.h
+include/libdaemon/dpid.h
+include/libdaemon/dsignal.h
+lib/libdaemon.a
+lib/libdaemon.so
+lib/libdaemon.so.2
+libdata/pkgconfig/libdaemon.pc
+@dirrm include/libdaemon