aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2016-10-29 20:01:54 +0800
committernovel <novel@FreeBSD.org>2016-10-29 20:01:54 +0800
commit9b5b3743eb42d23826d233322ffd4042487eace3 (patch)
tree3d8142a96ec8c88d967e63972a7d966d6b5a122b /devel
parentfa36eda902198ff0730a3525069c6be8205cbee6 (diff)
downloadfreebsd-ports-gnome-9b5b3743eb42d23826d233322ffd4042487eace3.tar.gz
freebsd-ports-gnome-9b5b3743eb42d23826d233322ffd4042487eace3.tar.zst
freebsd-ports-gnome-9b5b3743eb42d23826d233322ffd4042487eace3.zip
Add py-automaton 1.4.0, friendly state machines for python.
PR: 213769 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-automaton/Makefile23
-rw-r--r--devel/py-automaton/distinfo3
-rw-r--r--devel/py-automaton/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1aff62b009d3..239b89885c6a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4020,6 +4020,7 @@
SUBDIR += py-atomiclong
SUBDIR += py-atomicwrites
SUBDIR += py-attrs
+ SUBDIR += py-automaton
SUBDIR += py-avro
SUBDIR += py-babel
SUBDIR += py-babelfish
diff --git a/devel/py-automaton/Makefile b/devel/py-automaton/Makefile
new file mode 100644
index 000000000000..aaa5f83f9901
--- /dev/null
+++ b/devel/py-automaton/Makefile
@@ -0,0 +1,23 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= automaton
+PORTVERSION= 1.4.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= Friendly state machines for python
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}debtcollector>=1.2.0:devel/py-debtcollector \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0:devel/py-prettytable
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-automaton/distinfo b/devel/py-automaton/distinfo
new file mode 100644
index 000000000000..d3ad5a1fa561
--- /dev/null
+++ b/devel/py-automaton/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476648562
+SHA256 (automaton-1.4.0.tar.gz) = 27bc790506057d9ef2bcc6cd36d5039aa28ae1836d1afb14b1c7ed3d94f48aa6
+SIZE (automaton-1.4.0.tar.gz) = 24938
diff --git a/devel/py-automaton/pkg-descr b/devel/py-automaton/pkg-descr
new file mode 100644
index 000000000000..65ab84e57591
--- /dev/null
+++ b/devel/py-automaton/pkg-descr
@@ -0,0 +1,8 @@
+Friendly state machines for python. The goal of this library is to provide
+well documented state machine classes and associated utilities. The state
+machine pattern (or the implemented variation there-of) is a commonly used
+pattern and has a multitude of various usages. Some of the usages for this
+library include providing state & transition validation and
+running/scheduling/analyzing the execution of tasks.
+
+WWW: https://pypi.python.org/pypi/automaton