aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2015-05-16 19:48:18 +0800
committerkuriyama <kuriyama@FreeBSD.org>2015-05-16 19:48:18 +0800
commit9c406e85c23bbaeea3deab382106447955a0e127 (patch)
treea7e81f14ceb80b48cd97f84b29de184fa5fad705 /devel
parent6f35725ec62c262ec2b286d73ba93c2d986fe95a (diff)
downloadfreebsd-ports-gnome-9c406e85c23bbaeea3deab382106447955a0e127.tar.gz
freebsd-ports-gnome-9c406e85c23bbaeea3deab382106447955a0e127.tar.zst
freebsd-ports-gnome-9c406e85c23bbaeea3deab382106447955a0e127.zip
The most of the code of this module is taken from the PAUSE code as of
April 2013 almost verbatim. Thus, the heart of this module should be quite stable. However, I made it not to use pipe ("-|") as well as I stripped database-related code. If you encounter any issue, that's most probably because of my modification. This module doesn't provide features to extract a distribution or parse meta files intentionally. WWW: http://search.cpan.org/dist/Parse-PMFile/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Parse-PMFile/Makefile21
-rw-r--r--devel/p5-Parse-PMFile/distinfo2
-rw-r--r--devel/p5-Parse-PMFile/pkg-descr10
-rw-r--r--devel/p5-Parse-PMFile/pkg-plist2
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 75db4d0d915a..244d8caf0f0b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2686,6 +2686,7 @@
SUBDIR += p5-Parse-ErrorString-Perl
SUBDIR += p5-Parse-ExuberantCTags
SUBDIR += p5-Parse-Method-Signatures
+ SUBDIR += p5-Parse-PMFile
SUBDIR += p5-Parse-PerlConfig
SUBDIR += p5-Parse-Pidl
SUBDIR += p5-Parse-PlainConfig
diff --git a/devel/p5-Parse-PMFile/Makefile b/devel/p5-Parse-PMFile/Makefile
new file mode 100644
index 000000000000..4cdfed60adb5
--- /dev/null
+++ b/devel/p5-Parse-PMFile/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Parse-PMFile
+PORTVERSION= 0.36
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to parses .pm file as PAUSE does
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-ExtUtils-MakeMaker-CPANfile>0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker-CPANfile
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parse-PMFile/distinfo b/devel/p5-Parse-PMFile/distinfo
new file mode 100644
index 000000000000..65749e9102ce
--- /dev/null
+++ b/devel/p5-Parse-PMFile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Parse-PMFile-0.36.tar.gz) = 3d9fab94625eacc8c757f69152f43e936560e842c08b41496fba9035c66ba473
+SIZE (Parse-PMFile-0.36.tar.gz) = 14798
diff --git a/devel/p5-Parse-PMFile/pkg-descr b/devel/p5-Parse-PMFile/pkg-descr
new file mode 100644
index 000000000000..d90ca407a634
--- /dev/null
+++ b/devel/p5-Parse-PMFile/pkg-descr
@@ -0,0 +1,10 @@
+The most of the code of this module is taken from the PAUSE code as of
+April 2013 almost verbatim. Thus, the heart of this module should be
+quite stable. However, I made it not to use pipe ("-|") as well as I
+stripped database-related code. If you encounter any issue, that's
+most probably because of my modification.
+
+This module doesn't provide features to extract a distribution or
+parse meta files intentionally.
+
+WWW: http://search.cpan.org/dist/Parse-PMFile/
diff --git a/devel/p5-Parse-PMFile/pkg-plist b/devel/p5-Parse-PMFile/pkg-plist
new file mode 100644
index 000000000000..bc7d0ecec991
--- /dev/null
+++ b/devel/p5-Parse-PMFile/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Parse/PMFile.pm
+%%PERL5_MAN3%%/Parse::PMFile.3.gz