aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-12-31 07:46:31 +0800
committerjgh <jgh@FreeBSD.org>2013-12-31 07:46:31 +0800
commita3898ce37d25675062d1e334ebeea2bec104c35f (patch)
tree14d121f001612858743c1c1da225ecf1053e32ca /devel
parent26a4155248786526cd57835d2970c72fffaa6108 (diff)
downloadfreebsd-ports-gnome-a3898ce37d25675062d1e334ebeea2bec104c35f.tar.gz
freebsd-ports-gnome-a3898ce37d25675062d1e334ebeea2bec104c35f.tar.zst
freebsd-ports-gnome-a3898ce37d25675062d1e334ebeea2bec104c35f.zip
The sigrok project aims at creating a portable, cross-platform,
Free/Libre/Open-Source signal analysis software suite that supports various device types, such as logic analyzers, MSOs, oscilloscopes, multimeters, LCR meters, sound level meters, thermometers, hygrometers, anemometers, light meters, DAQs, dataloggers, function generators, spectrum analyzers, power supplies, GPIB interfaces, and more. WWW: http://sigrok.org/ PR: ports/179853 Submitted by: Uffe Jakobsen <uffe@uffe.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libsigrok/Makefile28
-rw-r--r--devel/libsigrok/distinfo2
-rw-r--r--devel/libsigrok/files/patch-hardware-lascar-el-usb-protocol.c12
-rw-r--r--devel/libsigrok/files/patch-hardware-victor-dmm-api.c12
-rw-r--r--devel/libsigrok/pkg-descr9
-rw-r--r--devel/libsigrok/pkg-plist9
7 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2c054db8c8f7..a103e794e891 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1091,6 +1091,7 @@
SUBDIR += libsigc++12
SUBDIR += libsigc++20
SUBDIR += libsigcx
+ SUBDIR += libsigrok
SUBDIR += libsigsegv
SUBDIR += libslang2
SUBDIR += libslave
diff --git a/devel/libsigrok/Makefile b/devel/libsigrok/Makefile
new file mode 100644
index 000000000000..e3652dfcca0c
--- /dev/null
+++ b/devel/libsigrok/Makefile
@@ -0,0 +1,28 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= libsigrok
+PORTVERSION= 0.2.0
+CATEGORIES= devel
+MASTER_SITES= http://sigrok.org/download/source/libsigrok/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Framework for hardware logic analyzers, core library
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libzip.so:${PORTSDIR}/archivers/libzip
+
+GNU_CONFIGURE= yes
+USES= gmake pkgconfig pathfix
+USE_GNOME= gtk20
+MAKE_JOBS_UNSAFE= yes
+USE_LDCONFIG= yes
+
+# Workaround for libusb not knowing LIBUSB_CLASS_APPLICATION
+CFLAGS+= -DLIBUSB_CLASS_APPLICATION=0xfe
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsigrok.so
+
+.include <bsd.port.mk>
diff --git a/devel/libsigrok/distinfo b/devel/libsigrok/distinfo
new file mode 100644
index 000000000000..ceac7ddf094d
--- /dev/null
+++ b/devel/libsigrok/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libsigrok-0.2.0.tar.gz) = 25b7930b7f5f0c3f8a8151e511cbffb97985f365fce338bb66f7bf111243b1de
+SIZE (libsigrok-0.2.0.tar.gz) = 852744
diff --git a/devel/libsigrok/files/patch-hardware-lascar-el-usb-protocol.c b/devel/libsigrok/files/patch-hardware-lascar-el-usb-protocol.c
new file mode 100644
index 000000000000..95dbcc53368f
--- /dev/null
+++ b/devel/libsigrok/files/patch-hardware-lascar-el-usb-protocol.c
@@ -0,0 +1,12 @@
+--- ./hardware/lascar-el-usb/protocol.c.orig 2013-06-22 17:57:14.000000000 +0200
++++ ./hardware/lascar-el-usb/protocol.c 2013-06-22 17:57:56.000000000 +0200
+@@ -512,8 +512,7 @@
+ }
+
+ memset(&tv, 0, sizeof(struct timeval));
+- libusb_handle_events_timeout_completed(drvc->sr_ctx->libusb_ctx, &tv,
+- NULL);
++ libusb_handle_events_timeout(drvc->sr_ctx->libusb_ctx, &tv);
+
+ return TRUE;
+ }
diff --git a/devel/libsigrok/files/patch-hardware-victor-dmm-api.c b/devel/libsigrok/files/patch-hardware-victor-dmm-api.c
new file mode 100644
index 000000000000..fd04ff1809b0
--- /dev/null
+++ b/devel/libsigrok/files/patch-hardware-victor-dmm-api.c
@@ -0,0 +1,12 @@
+--- ./hardware/victor-dmm/api.c.orig 2013-06-22 17:57:10.000000000 +0200
++++ ./hardware/victor-dmm/api.c 2013-06-22 17:57:36.000000000 +0200
+@@ -379,8 +379,7 @@
+ }
+
+ memset(&tv, 0, sizeof(struct timeval));
+- libusb_handle_events_timeout_completed(drvc->sr_ctx->libusb_ctx, &tv,
+- NULL);
++ libusb_handle_events_timeout(drvc->sr_ctx->libusb_ctx, &tv);
+
+ return TRUE;
+ }
diff --git a/devel/libsigrok/pkg-descr b/devel/libsigrok/pkg-descr
new file mode 100644
index 000000000000..18801e879571
--- /dev/null
+++ b/devel/libsigrok/pkg-descr
@@ -0,0 +1,9 @@
+The sigrok project aims at creating a portable, cross-platform,
+Free/Libre/Open-Source signal analysis software suite that supports
+various device types, such as logic analyzers, MSOs, oscilloscopes,
+multimeters, LCR meters, sound level meters, thermometers,
+hygrometers, anemometers, light meters, DAQs, dataloggers,
+function generators, spectrum analyzers, power supplies,
+GPIB interfaces, and more.
+
+WWW: http://sigrok.org/
diff --git a/devel/libsigrok/pkg-plist b/devel/libsigrok/pkg-plist
new file mode 100644
index 000000000000..c4d5b82e718a
--- /dev/null
+++ b/devel/libsigrok/pkg-plist
@@ -0,0 +1,9 @@
+include/libsigrok/libsigrok.h
+include/libsigrok/proto.h
+include/libsigrok/version.h
+lib/libsigrok.a
+lib/libsigrok.la
+lib/libsigrok.so
+lib/libsigrok.so.1
+libdata/pkgconfig/libsigrok.pc
+@dirrm include/libsigrok