aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-08-14 05:25:33 +0800
committerrm <rm@FreeBSD.org>2015-08-14 05:25:33 +0800
commita4af020b9f05c9ddd0d02856deaad972190a61e8 (patch)
tree5bdc6f65bfcbed74f6781402772a9c6925c20fd2 /devel
parent0a48d8af7ef7bbbe28de5db53619c65bca7199b5 (diff)
downloadfreebsd-ports-gnome-a4af020b9f05c9ddd0d02856deaad972190a61e8.tar.gz
freebsd-ports-gnome-a4af020b9f05c9ddd0d02856deaad972190a61e8.tar.zst
freebsd-ports-gnome-a4af020b9f05c9ddd0d02856deaad972190a61e8.zip
API to extract data from HTML and XML documents.
WWW: https://pypi.python.org/pypi/selection
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-selection/Makefile25
-rw-r--r--devel/py-selection/distinfo2
-rw-r--r--devel/py-selection/files/patch-setup.py11
-rw-r--r--devel/py-selection/pkg-descr3
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b83f5e875b38..4f820181a839 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4186,6 +4186,7 @@
SUBDIR += py-sanetime
SUBDIR += py-scripttest
SUBDIR += py-sdl2
+ SUBDIR += py-selection
SUBDIR += py-semantic_version
SUBDIR += py-serpent
SUBDIR += py-setproctitle
diff --git a/devel/py-selection/Makefile b/devel/py-selection/Makefile
new file mode 100644
index 000000000000..0398593d9743
--- /dev/null
+++ b/devel/py-selection/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= selection
+PORTVERSION= 0.0.9
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= API to extract content from HTML & XML documents
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}weblib>0:${PORTSDIR}/devel/py-weblib
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-extract:
+ ${RM} -rf ${WRKSRC}/test
+
+.include <bsd.port.mk>
diff --git a/devel/py-selection/distinfo b/devel/py-selection/distinfo
new file mode 100644
index 000000000000..a6558acc705a
--- /dev/null
+++ b/devel/py-selection/distinfo
@@ -0,0 +1,2 @@
+SHA256 (selection-0.0.9.tar.gz) = 2e89d6eea792447a7c23da77b81fd7df84526791f64cbff4a50edf363697759e
+SIZE (selection-0.0.9.tar.gz) = 5979
diff --git a/devel/py-selection/files/patch-setup.py b/devel/py-selection/files/patch-setup.py
new file mode 100644
index 000000000000..46f143ab073c
--- /dev/null
+++ b/devel/py-selection/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2015-04-16 10:03:43 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ setup(
+ author = 'Gregory Petukhov',
+ author_email = 'lorien@lorien.name',
+ install_requires = ['lxml', 'weblib', 'six'],
+- packages = ['selection', 'selection.backend', 'test'],
++ packages = ['selection', 'selection.backend'],
+ license = "MIT",
+ classifiers = (
+ 'Programming Language :: Python',
diff --git a/devel/py-selection/pkg-descr b/devel/py-selection/pkg-descr
new file mode 100644
index 000000000000..7648b76b54bd
--- /dev/null
+++ b/devel/py-selection/pkg-descr
@@ -0,0 +1,3 @@
+API to extract data from HTML and XML documents.
+
+WWW: https://pypi.python.org/pypi/selection