aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2004-07-27 22:23:39 +0800
committertobez <tobez@FreeBSD.org>2004-07-27 22:23:39 +0800
commita596006c0a3fd877dfc3b2edac1554f6a433602a (patch)
treee06fc65290f1d5c0c99275961f2edcdcb7c55885 /devel
parent9ac46363f18531f45460878d2e46aae0377e19a6 (diff)
downloadfreebsd-ports-gnome-a596006c0a3fd877dfc3b2edac1554f6a433602a.tar.gz
freebsd-ports-gnome-a596006c0a3fd877dfc3b2edac1554f6a433602a.tar.zst
freebsd-ports-gnome-a596006c0a3fd877dfc3b2edac1554f6a433602a.zip
Add p5-Tie-Array-Sorted, an implementation of Perl array which is kept
sorted.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tie-Array-Sorted/Makefile28
-rw-r--r--devel/p5-Tie-Array-Sorted/distinfo2
-rw-r--r--devel/p5-Tie-Array-Sorted/pkg-descr9
-rw-r--r--devel/p5-Tie-Array-Sorted/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4fe797a2d604..a3c59bd1f090 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -968,6 +968,7 @@
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Simple
SUBDIR += p5-Test-Unit
+ SUBDIR += p5-Tie-Array-Sorted
SUBDIR += p5-Tie-Cache
SUBDIR += p5-Tie-DB_File-SplitHash
SUBDIR += p5-Tie-DB_FileLock
diff --git a/devel/p5-Tie-Array-Sorted/Makefile b/devel/p5-Tie-Array-Sorted/Makefile
new file mode 100644
index 000000000000..b0929c11931e
--- /dev/null
+++ b/devel/p5-Tie-Array-Sorted/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Tie-Array-Sorted
+# Date created: 27 July 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-Array-Sorted
+PORTVERSION= 1.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A Perl array which is kept sorted
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::Array::Sorted.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port requires perl 5.6 or above."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Tie-Array-Sorted/distinfo b/devel/p5-Tie-Array-Sorted/distinfo
new file mode 100644
index 000000000000..7462df43a859
--- /dev/null
+++ b/devel/p5-Tie-Array-Sorted/distinfo
@@ -0,0 +1,2 @@
+MD5 (Tie-Array-Sorted-1.2.tar.gz) = 333ad6fa28418d396a4e9ff19c3a0b89
+SIZE (Tie-Array-Sorted-1.2.tar.gz) = 3329
diff --git a/devel/p5-Tie-Array-Sorted/pkg-descr b/devel/p5-Tie-Array-Sorted/pkg-descr
new file mode 100644
index 000000000000..d23da939f9d8
--- /dev/null
+++ b/devel/p5-Tie-Array-Sorted/pkg-descr
@@ -0,0 +1,9 @@
+Tie::Array::Sorted represents an ordinary array, which is kept sorted.
+All pushes and unshifts cause the elements in question to be inserted in
+the appropriate location to maintain order.
+
+Direct stores ($a[10] = "wibble") effectively splice out the original
+value and insert the new element. It's not clear why you'd want to use
+direct stores like that, but this module does the right thing if you do.
+
+WWW: http://search.cpan.org/dist/Tie-Array-Sorted/
diff --git a/devel/p5-Tie-Array-Sorted/pkg-plist b/devel/p5-Tie-Array-Sorted/pkg-plist
new file mode 100644
index 000000000000..3aa1efbea10e
--- /dev/null
+++ b/devel/p5-Tie-Array-Sorted/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Array/Sorted/.packlist
+%%SITE_PERL%%/Tie/Array/Sorted.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Array/Sorted
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Array 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tie/Array 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tie 2>/dev/null || true