aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-05-19 21:31:44 +0800
committerijliao <ijliao@FreeBSD.org>2001-05-19 21:31:44 +0800
commita9fbb573ae819cf71b35ef85859d0911cf622d9a (patch)
treec43698b534d4b802107fea011b2dfa57b161270b /devel
parenta2ef525015d10d1bbd47a0fda776713618fe2a62 (diff)
downloadfreebsd-ports-gnome-a9fbb573ae819cf71b35ef85859d0911cf622d9a.tar.gz
freebsd-ports-gnome-a9fbb573ae819cf71b35ef85859d0911cf622d9a.tar.zst
freebsd-ports-gnome-a9fbb573ae819cf71b35ef85859d0911cf622d9a.zip
add p5-Heap
Perl extensions for keeping data partially sorted PR: 26389 Submitted by: Anatoliy Dmytriyev <tolid@plab.ku.dk>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Heap/Makefile25
-rw-r--r--devel/p5-Heap/distinfo1
-rw-r--r--devel/p5-Heap/pkg-comment1
-rw-r--r--devel/p5-Heap/pkg-descr4
-rw-r--r--devel/p5-Heap/pkg-plist36
6 files changed, 68 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4150333adf19..6f84d2c0c2c2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -300,6 +300,7 @@
SUBDIR += p5-File-Tools
SUBDIR += p5-Filter
SUBDIR += p5-FreezeThaw
+ SUBDIR += p5-Heap
SUBDIR += p5-IO
SUBDIR += p5-IO-String
SUBDIR += p5-IO-Stty
diff --git a/devel/p5-Heap/Makefile b/devel/p5-Heap/Makefile
new file mode 100644
index 000000000000..31d827156b8e
--- /dev/null
+++ b/devel/p5-Heap/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Heap
+# Date created: 6 April 2001
+# Whom: Anatoliy Dmytriyev
+#
+# $FreeBSD$
+#
+
+PORTNAME= Heap
+PORTVERSION= 0.50
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Heap
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tolid@plab.ku.dk
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Heap.3 Heap::Binary.3 Heap::Binomial.3 Heap::Elem::Num.3 \
+ Heap::Elem::NumRev.3 Heap::Elem::Ref.3 Heap::Elem::RefRev.3 \
+ Heap::Elem::Str.3 Heap::Elem::StrRev.3 Heap::Elem.3 \
+ Heap::Fibonacci.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Heap/distinfo b/devel/p5-Heap/distinfo
new file mode 100644
index 000000000000..03bd1b192f3b
--- /dev/null
+++ b/devel/p5-Heap/distinfo
@@ -0,0 +1 @@
+MD5 (Heap-0.50.tar.gz) = f23fc81b84101719e88c66a872611e78
diff --git a/devel/p5-Heap/pkg-comment b/devel/p5-Heap/pkg-comment
new file mode 100644
index 000000000000..d5cf4eec2eff
--- /dev/null
+++ b/devel/p5-Heap/pkg-comment
@@ -0,0 +1 @@
+Perl extensions for keeping data partially sorted
diff --git a/devel/p5-Heap/pkg-descr b/devel/p5-Heap/pkg-descr
new file mode 100644
index 000000000000..48e2e9fd2de9
--- /dev/null
+++ b/devel/p5-Heap/pkg-descr
@@ -0,0 +1,4 @@
+The Heap collection of modules provide routines that manage a heap of elements.
+A heap is a partially sorted structure that is always able to easily extract
+the smallest of the elements in the structure (or the largest if a reversed
+compare routine is provided).
diff --git a/devel/p5-Heap/pkg-plist b/devel/p5-Heap/pkg-plist
new file mode 100644
index 000000000000..69980d1c35db
--- /dev/null
+++ b/devel/p5-Heap/pkg-plist
@@ -0,0 +1,36 @@
+lib/perl5/site_perl/%%PERL_VER%%/Heap.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Binary.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Binomial.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem/Num.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem/NumRev.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem/Ref.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem/RefRev.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem/Str.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem/StrRev.pm
+lib/perl5/site_perl/%%PERL_VER%%/Heap/Fibonacci.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Heap/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Binary/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Binomial/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/Num/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/NumRev/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/Ref/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/RefRev/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/Str/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/StrRev/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Fibonacci/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Heap/Elem
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Heap
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Binary
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Binomial
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Fibonacci
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/Num
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/NumRev
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/Ref
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/RefRev
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/Str
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem/StrRev
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap/Elem
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Heap