aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-27 15:37:57 +0800
committermiwi <miwi@FreeBSD.org>2007-03-27 15:37:57 +0800
commitaa8c041ebf278c731857f534253e59abefdddfa9 (patch)
treeec37c7e21d0ed20fca4d5479f4133a24c929f356 /devel
parentc69529b72d4efdeaaeee9334665205365e36924d (diff)
downloadfreebsd-ports-gnome-aa8c041ebf278c731857f534253e59abefdddfa9.tar.gz
freebsd-ports-gnome-aa8c041ebf278c731857f534253e59abefdddfa9.tar.zst
freebsd-ports-gnome-aa8c041ebf278c731857f534253e59abefdddfa9.zip
- Fix the permission of bin/bnfc, binary executable should use INSTALL_PROGRAM
- NOPORTDOCS shoule not apply to things in EXAMPLESDIR - We can use bsd.port.mk in this port PR: 110852 Submitted by: Li-Wen Hsu <lwhsu@lwhsu.org> Approved by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/bnfc/Makefile12
-rw-r--r--devel/bnfc/pkg-plist48
-rw-r--r--devel/hs-BNFC/Makefile12
-rw-r--r--devel/hs-BNFC/pkg-plist48
4 files changed, 60 insertions, 60 deletions
diff --git a/devel/bnfc/Makefile b/devel/bnfc/Makefile
index 3bd6fe2a9cf8..bb4b478d0c2d 100644
--- a/devel/bnfc/Makefile
+++ b/devel/bnfc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bnfc
PORTVERSION= 2.3b
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cs.chalmers.se/~markus/BNFC/ \
http://www.cs.chalmers.se/Cs/Grundutb/Kurser/komp/current/resources/
@@ -20,18 +21,17 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
do-install:
- ${INSTALL_DATA} ${WRKSRC}/bnfc ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bnfc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
post-install:
+ ${RM} -f ${WRKSRC}/examples/.cvsignore
${RM} -f ${WRKSRC}/examples/haskell-core/.cvsignore
${MKDIR} ${EXAMPLESDIR}
- ${CP} -pR ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/LBNF-report.tex ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/bnfc/pkg-plist b/devel/bnfc/pkg-plist
index e74a5547a228..420a77665445 100644
--- a/devel/bnfc/pkg-plist
+++ b/devel/bnfc/pkg-plist
@@ -1,27 +1,27 @@
bin/bnfc
+%%EXAMPLESDIR%%/C4.cf
+%%EXAMPLESDIR%%/JavaletteLight.cf
+%%EXAMPLESDIR%%/OCL.cf
+%%EXAMPLESDIR%%/Prolog.cf
+%%EXAMPLESDIR%%/fstStudio.cf
+%%EXAMPLESDIR%%/haskell-core/AbsCore.hcr
+%%EXAMPLESDIR%%/haskell-core/Core.cf
+%%EXAMPLESDIR%%/haskell-core/Hello.hcr
+%%EXAMPLESDIR%%/haskell-core/ParCore.hcr
+%%EXAMPLESDIR%%/haskell-core/README
+%%EXAMPLESDIR%%/haskell-core/TopCore.hs
+%%EXAMPLESDIR%%/haskell-core/notes.txt
+%%EXAMPLESDIR%%/koe.jll
+%%EXAMPLESDIR%%/koe2.c
+%%EXAMPLESDIR%%/multi/Arithm.cf
+%%EXAMPLESDIR%%/multi/TestArithm.hs
+%%EXAMPLESDIR%%/multi/types/Types.cf
+%%EXAMPLESDIR%%/multi/types/ex.old
+%%EXAMPLESDIR%%/prolog.pl
+%%EXAMPLESDIR%%/small.pl
+@dirrm %%EXAMPLESDIR%%/multi/types
+@dirrm %%EXAMPLESDIR%%/multi
+@dirrm %%EXAMPLESDIR%%/haskell-core
+@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/LBNF-report.tex
-%%PORTDOCS%%%%EXAMPLESDIR%%/C4.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/JavaletteLight.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/OCL.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/Prolog.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/fstStudio.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/AbsCore.hcr
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/Core.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/Hello.hcr
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/ParCore.hcr
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/TopCore.hs
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/notes.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/koe.jll
-%%PORTDOCS%%%%EXAMPLESDIR%%/koe2.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/Arithm.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/TestArithm.hs
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/types/Types.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/types/ex.old
-%%PORTDOCS%%%%EXAMPLESDIR%%/prolog.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/small.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/multi/types
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/multi
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/haskell-core
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/devel/hs-BNFC/Makefile b/devel/hs-BNFC/Makefile
index 3bd6fe2a9cf8..bb4b478d0c2d 100644
--- a/devel/hs-BNFC/Makefile
+++ b/devel/hs-BNFC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bnfc
PORTVERSION= 2.3b
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cs.chalmers.se/~markus/BNFC/ \
http://www.cs.chalmers.se/Cs/Grundutb/Kurser/komp/current/resources/
@@ -20,18 +21,17 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
do-install:
- ${INSTALL_DATA} ${WRKSRC}/bnfc ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bnfc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
post-install:
+ ${RM} -f ${WRKSRC}/examples/.cvsignore
${RM} -f ${WRKSRC}/examples/haskell-core/.cvsignore
${MKDIR} ${EXAMPLESDIR}
- ${CP} -pR ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/LBNF-report.tex ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/hs-BNFC/pkg-plist b/devel/hs-BNFC/pkg-plist
index e74a5547a228..420a77665445 100644
--- a/devel/hs-BNFC/pkg-plist
+++ b/devel/hs-BNFC/pkg-plist
@@ -1,27 +1,27 @@
bin/bnfc
+%%EXAMPLESDIR%%/C4.cf
+%%EXAMPLESDIR%%/JavaletteLight.cf
+%%EXAMPLESDIR%%/OCL.cf
+%%EXAMPLESDIR%%/Prolog.cf
+%%EXAMPLESDIR%%/fstStudio.cf
+%%EXAMPLESDIR%%/haskell-core/AbsCore.hcr
+%%EXAMPLESDIR%%/haskell-core/Core.cf
+%%EXAMPLESDIR%%/haskell-core/Hello.hcr
+%%EXAMPLESDIR%%/haskell-core/ParCore.hcr
+%%EXAMPLESDIR%%/haskell-core/README
+%%EXAMPLESDIR%%/haskell-core/TopCore.hs
+%%EXAMPLESDIR%%/haskell-core/notes.txt
+%%EXAMPLESDIR%%/koe.jll
+%%EXAMPLESDIR%%/koe2.c
+%%EXAMPLESDIR%%/multi/Arithm.cf
+%%EXAMPLESDIR%%/multi/TestArithm.hs
+%%EXAMPLESDIR%%/multi/types/Types.cf
+%%EXAMPLESDIR%%/multi/types/ex.old
+%%EXAMPLESDIR%%/prolog.pl
+%%EXAMPLESDIR%%/small.pl
+@dirrm %%EXAMPLESDIR%%/multi/types
+@dirrm %%EXAMPLESDIR%%/multi
+@dirrm %%EXAMPLESDIR%%/haskell-core
+@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/LBNF-report.tex
-%%PORTDOCS%%%%EXAMPLESDIR%%/C4.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/JavaletteLight.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/OCL.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/Prolog.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/fstStudio.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/AbsCore.hcr
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/Core.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/Hello.hcr
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/ParCore.hcr
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/TopCore.hs
-%%PORTDOCS%%%%EXAMPLESDIR%%/haskell-core/notes.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/koe.jll
-%%PORTDOCS%%%%EXAMPLESDIR%%/koe2.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/Arithm.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/TestArithm.hs
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/types/Types.cf
-%%PORTDOCS%%%%EXAMPLESDIR%%/multi/types/ex.old
-%%PORTDOCS%%%%EXAMPLESDIR%%/prolog.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/small.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/multi/types
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/multi
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/haskell-core
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%