aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-04-23 19:06:03 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-04-23 19:06:03 +0800
commitab790fe682cae71b68b998cb74e868a4973c6e18 (patch)
tree3ac0905cc2ef0120dde2624d8553c6ff031a0dd7 /devel
parent24aef40b3cf8d3ee33b5e8605cab04bbe8d2d3d9 (diff)
downloadfreebsd-ports-gnome-ab790fe682cae71b68b998cb74e868a4973c6e18.tar.gz
freebsd-ports-gnome-ab790fe682cae71b68b998cb74e868a4973c6e18.tar.zst
freebsd-ports-gnome-ab790fe682cae71b68b998cb74e868a4973c6e18.zip
- Fix ccache for CURRENT world builds by automatically defining
CCACHE_CPP2=1 when COMPILER_TYPE=clang (this will be removed once upstream fixes the issue). This does not address port builds yet. - Add more hints for building with clang - Split MASTER_SITES into 2 lines - Note that textproc/libexttextcat is an example port that currently fails to build with clang+ccache due to bug 8118 ('unused -I'). I plan to add the upstream patch to fix this after more testing.
Diffstat (limited to 'devel')
-rw-r--r--devel/ccache/Makefile4
-rw-r--r--devel/ccache/files/pkg-message-clang5
-rw-r--r--devel/ccache/files/world-ccache.in2
3 files changed, 9 insertions, 2 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 5664840b4113..9a32537e34e6 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -3,8 +3,10 @@
PORTNAME= ccache
PORTVERSION= 3.1.9
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= http://www.samba.org/ftp/ccache/ CRITICAL
+MASTER_SITES= http://www.samba.org/ftp/ccache/ \
+ CRITICAL
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Tool to minimize the compile time of C/C++ programs
diff --git a/devel/ccache/files/pkg-message-clang b/devel/ccache/files/pkg-message-clang
index b572ebfe3c97..eed5a090ca37 100644
--- a/devel/ccache/files/pkg-message-clang
+++ b/devel/ccache/files/pkg-message-clang
@@ -2,6 +2,9 @@ You've chosen to create symlinks to the clang compiler binaries if they exist.
While it's known to be safe to build world with clang/ccache, it is not fully
supported yet. You have been warned.
+You should define CCACHE_CPP2=1 in your /etc/make.conf until bug 8460 is fixed.
+
See:
-https://bugzilla.samba.org/show_bug.cgi?id=8460
+ https://bugzilla.samba.org/show_bug.cgi?id=8460
+ https://bugzilla.samba.org/show_bug.cgi?id=8118
diff --git a/devel/ccache/files/world-ccache.in b/devel/ccache/files/world-ccache.in
index 2b27aeefeb3f..bdbc8893837f 100644
--- a/devel/ccache/files/world-ccache.in
+++ b/devel/ccache/files/world-ccache.in
@@ -4,6 +4,8 @@
printf "Please, use one of the compiler links in\n%%PREFIX%%/%%CCLINKDIR%%/world\nto invoke ccache\n" >&2 &&
exit 1
+[ "${COMPILER_TYPE}" = "clang" ] && export CCACHE_CPP2=1
+
unset CCACHE_PATH
export CCACHE_COMPILERCHECK=content
exec %%PREFIX%%/%%CCLINKDIR%%/${0##*/} "$@"