aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-08-30 01:27:41 +0800
committergarga <garga@FreeBSD.org>2006-08-30 01:27:41 +0800
commitac208b0b6f6af1515add8b269b940b63608a2e32 (patch)
tree3fc016bd6a5f2f6cf6a8ee16f042fe26504d9b18 /devel
parent924a9be1b65c9ee2298950e3907bd90267fc87c1 (diff)
downloadfreebsd-ports-gnome-ac208b0b6f6af1515add8b269b940b63608a2e32.tar.gz
freebsd-ports-gnome-ac208b0b6f6af1515add8b269b940b63608a2e32.tar.zst
freebsd-ports-gnome-ac208b0b6f6af1515add8b269b940b63608a2e32.zip
Generate is a text preprocessor that I originally wrote to help me write
custom accounting applications based on the Progress database product. I felt that the built in wasn't useful enough so I designed a new one and implemented it. It actually started life as a package configuration and batch file generator for DOS and mutated to a simple script interpreter to replace shar file distribution. At this point it has almost nothing in common with that first program. The basic idea behind generate is to create a script which generates files. There is some simple flow control constructs but the power lies in its macro processing. I have shamelessly stolen ideas from cpp, m4, make and David Tilbrook's dtree. WWW: http://www.druid.net/darcy/readme-generate.html PR: ports/102507 Submitted by: D'Arcy J.M. Cain <darcy at druid.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/generate/Makefile26
-rw-r--r--devel/generate/distinfo3
-rw-r--r--devel/generate/pkg-descr14
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 340c263afa45..8a04a2c97b64 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -330,6 +330,7 @@
SUBDIR += gdb6
SUBDIR += gdbmods
SUBDIR += geany
+ SUBDIR += generate
SUBDIR += gengameng
SUBDIR += gengetopt
SUBDIR += genproto
diff --git a/devel/generate/Makefile b/devel/generate/Makefile
new file mode 100644
index 000000000000..8d38c2b26723
--- /dev/null
+++ b/devel/generate/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: generate
+# Date created: 24 August 2006
+# Whom: D'Arcy J.M. Cain <darcy@druid.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= generate
+PORTVERSION= 2.3
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= darcy@druid.net
+COMMENT= Simple text pre-processor
+
+USE_GMAKE= yes
+MAN1= generate.1
+
+PLIST_FILES= bin/generate bin/rgenerate
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CFLAGS *=,CFLAGS +=,' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/generate/distinfo b/devel/generate/distinfo
new file mode 100644
index 000000000000..b605dd5d50b4
--- /dev/null
+++ b/devel/generate/distinfo
@@ -0,0 +1,3 @@
+MD5 (generate-2.3.tgz) = 17862c9fc365796a833b4f45b54518e7
+SHA256 (generate-2.3.tgz) = 8601c705be9ae1a0674d07d3d38f4dfbdf732014819eb44ac70ea3d884119861
+SIZE (generate-2.3.tgz) = 28752
diff --git a/devel/generate/pkg-descr b/devel/generate/pkg-descr
new file mode 100644
index 000000000000..c71da043afcf
--- /dev/null
+++ b/devel/generate/pkg-descr
@@ -0,0 +1,14 @@
+Generate is a text preprocessor that I originally wrote to help me write
+custom accounting applications based on the Progress database product. I
+felt that the built in wasn't useful enough so I designed a new one and
+implemented it. It actually started life as a package configuration and
+batch file generator for DOS and mutated to a simple script interpreter
+to replace shar file distribution. At this point it has almost nothing in
+common with that first program.
+
+The basic idea behind generate is to create a script which generates files.
+There is some simple flow control constructs but the power lies in its
+macro processing. I have shamelessly stolen ideas from cpp, m4, make and
+David Tilbrook's dtree.
+
+WWW: http://www.druid.net/darcy/readme-generate.html