aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-03-10 14:12:11 +0800
committervanilla <vanilla@FreeBSD.org>2015-03-10 14:12:11 +0800
commitb192a218dbcffd15791e69767ec3c83d248c35a1 (patch)
tree2faf1a2c5b3f7d66b0a115f1b061c9d348812556 /devel
parentce2988bfe41d8deea6de27a5c28670fdabf12871 (diff)
downloadfreebsd-ports-gnome-b192a218dbcffd15791e69767ec3c83d248c35a1.tar.gz
freebsd-ports-gnome-b192a218dbcffd15791e69767ec3c83d248c35a1.tar.zst
freebsd-ports-gnome-b192a218dbcffd15791e69767ec3c83d248c35a1.zip
Add p5-Algorithm-Cron 0.09, abstract implementation of the cron(8)
scheduling algorithm. PR: 198308 Submitted by: Geoffroy Desvernay <dgeo@centrale-marseille.fr>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-Cron/Makefile22
-rw-r--r--devel/p5-Algorithm-Cron/distinfo2
-rw-r--r--devel/p5-Algorithm-Cron/pkg-descr7
-rw-r--r--devel/p5-Algorithm-Cron/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4f01a6860e83..95fb3a296ce0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1452,6 +1452,7 @@
SUBDIR += p5-Algorithm-C3
SUBDIR += p5-Algorithm-ChooseSubsets
SUBDIR += p5-Algorithm-Cluster
+ SUBDIR += p5-Algorithm-Cron
SUBDIR += p5-Algorithm-Dependency
SUBDIR += p5-Algorithm-Dependency-Objects
SUBDIR += p5-Algorithm-Diff
diff --git a/devel/p5-Algorithm-Cron/Makefile b/devel/p5-Algorithm-Cron/Makefile
new file mode 100644
index 000000000000..71719e43e8d5
--- /dev/null
+++ b/devel/p5-Algorithm-Cron/Makefile
@@ -0,0 +1,22 @@
+# Created by: Geoffroy Desvernay <dgeo@centrale-marseille.fr>
+# $FreeBSD$
+
+PORTNAME= Algorithm-Cron
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dgeo@centrale-marseille.fr
+COMMENT= Abstract implementation of the cron(8) scheduling algorithm
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS:= p5-Time-timegm>=0:${PORTSDIR}/devel/p5-Time-timegm
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-Cron/distinfo b/devel/p5-Algorithm-Cron/distinfo
new file mode 100644
index 000000000000..1157dd690811
--- /dev/null
+++ b/devel/p5-Algorithm-Cron/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Algorithm-Cron-0.09.tar.gz) = 16ca57e6556c0cfa51e5634a91be97d2f0ebbccc52bada568021cb2be7e0602a
+SIZE (Algorithm-Cron-0.09.tar.gz) = 18233
diff --git a/devel/p5-Algorithm-Cron/pkg-descr b/devel/p5-Algorithm-Cron/pkg-descr
new file mode 100644
index 000000000000..b99e545a64dd
--- /dev/null
+++ b/devel/p5-Algorithm-Cron/pkg-descr
@@ -0,0 +1,7 @@
+Algorithm::Cron - abstract implementation of the cron(8) scheduling algorithm
+
+Objects in this class implement a time scheduling algorithm such as used by
+cron(8). Objects are stateless once constructed, and represent a single schedule
+ as defined by a crontab(5) entry. The object implements a method next_time
+which returns an epoch timestamp value to indicate the next time included
+in the crontab schedule.
diff --git a/devel/p5-Algorithm-Cron/pkg-plist b/devel/p5-Algorithm-Cron/pkg-plist
new file mode 100644
index 000000000000..9fa350fb7538
--- /dev/null
+++ b/devel/p5-Algorithm-Cron/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/Algorithm::Cron.3.gz
+%%SITE_PERL%%/Algorithm/Cron.pm