aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2007-03-24 14:33:10 +0800
committerleeym <leeym@FreeBSD.org>2007-03-24 14:33:10 +0800
commitb35cc2f7a68a603c1054ad87605c681434984865 (patch)
tree5da852e2b77d47db7cbad81d6381565500d158a4 /devel
parent03f8cef84de7edf7bd2f8a9163093fc15bccb351 (diff)
downloadfreebsd-ports-gnome-b35cc2f7a68a603c1054ad87605c681434984865.tar.gz
freebsd-ports-gnome-b35cc2f7a68a603c1054ad87605c681434984865.tar.zst
freebsd-ports-gnome-b35cc2f7a68a603c1054ad87605c681434984865.zip
<quoted from pkg-descr>
This is a port of Solaris libumem to non-Solaris systems. The port was made while integrating libumem with our Ecelerity MTA product, so your initial experience will not be 100% out-of-the-box, because there is no standalone configure script for the library at this time. (patches welcome!) In addition, since our deployment is threaded, we force the library into threaded mode. While the library is itself stable (it's the memory allocator used by the Solaris OS), the port may have a few rough edges. We're shipping umem with Linux and Windows versions of our product as we have found it to be stable. We will continue to update this project as and when we make improvements, and welcome third-party patches that improve the usability for everyone. Wez Furlong, OmniTI, Inc. </quoted from pkg-descr> This port is not yet fully tested, however, "br" <bf2006a at yahoo.com> is helping me to evaluate it. And also, he encourages me to commit my code so that more people would know about it. Reference: http://www.freebsd.org/projects/ideas/#p-libumem
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/umem/Makefile32
-rw-r--r--devel/umem/distinfo3
-rw-r--r--devel/umem/pkg-descr24
-rw-r--r--devel/umem/pkg-plist11
5 files changed, 71 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d33522a2ff2f..c8c8d71e4827 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2110,6 +2110,7 @@
SUBDIR += uclmmbase
SUBDIR += ucpp
SUBDIR += udis86
+ SUBDIR += umem
SUBDIR += upnp
SUBDIR += upnp104
SUBDIR += upp
diff --git a/devel/umem/Makefile b/devel/umem/Makefile
new file mode 100644
index 000000000000..50bc925dfb8b
--- /dev/null
+++ b/devel/umem/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: umem
+# Date created: 02 October 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= umem
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= https://labs.omniti.com/portableumem/releases/${PORTVERSION}/
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A port of the Solaris memory allocator
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/ -ldl//g' ${WRKSRC}/Makefile.in
+
+MAN3= umem_alloc.3 umem_cache_create.3 umem_debug.3
+
+.include <bsd.port.pre.mk>
+
+# pthread
+.if ${OSVERSION} < 502102
+IGNORE= requires FreeBSD 5.2.1 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/umem/distinfo b/devel/umem/distinfo
new file mode 100644
index 000000000000..b5b8c331601d
--- /dev/null
+++ b/devel/umem/distinfo
@@ -0,0 +1,3 @@
+MD5 (umem-1.0.tar.bz2) = 9b5d885998b25fc88b1df03088d7fb8c
+SHA256 (umem-1.0.tar.bz2) = 0c38273606e4cc435b27ab110cde2bc242e2187a66a4d1ae4688696338f60417
+SIZE (umem-1.0.tar.bz2) = 266805
diff --git a/devel/umem/pkg-descr b/devel/umem/pkg-descr
new file mode 100644
index 000000000000..72e59b3c1e1a
--- /dev/null
+++ b/devel/umem/pkg-descr
@@ -0,0 +1,24 @@
+Portable libumem.
+================
+
+This is a port of Solaris libumem to non-Solaris systems.
+
+The port was made while integrating libumem with our Ecelerity MTA product, so
+your initial experience will not be 100% out-of-the-box, because there is no
+standalone configure script for the library at this time. (patches welcome!)
+
+In addition, since our deployment is threaded, we force the library into
+threaded mode.
+
+While the library is itself stable (it's the memory allocator used by the
+Solaris OS), the port may have a few rough edges. We're shipping umem with
+Linux and Windows versions of our product as we have found it to be stable.
+
+We will continue to update this project as and when we make improvements, and
+welcome third-party patches that improve the usability for everyone.
+
+
+Wez Furlong,
+OmniTI, Inc.
+
+WWW: https://labs.omniti.com/trac/portableumem/
diff --git a/devel/umem/pkg-plist b/devel/umem/pkg-plist
new file mode 100644
index 000000000000..eb2e95081840
--- /dev/null
+++ b/devel/umem/pkg-plist
@@ -0,0 +1,11 @@
+include/sys/vmem.h
+include/umem.h
+lib/libumem.a
+lib/libumem.la
+lib/libumem.so
+lib/libumem.so.0
+lib/libumem_malloc.a
+lib/libumem_malloc.la
+lib/libumem_malloc.so
+lib/libumem_malloc.so.0
+@dirrmtry include/sys