aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2008-03-10 05:07:45 +0800
committerobraun <obraun@FreeBSD.org>2008-03-10 05:07:45 +0800
commitb72673c9fbc860c63a360695cab90835fb98a7d6 (patch)
treed417e6b7f8d1ee6c89f3526462693bb1dc77072f /devel
parent9efb09fbb3532a1f3dc747b6310610122b2c4f5c (diff)
downloadfreebsd-ports-gnome-b72673c9fbc860c63a360695cab90835fb98a7d6.tar.gz
freebsd-ports-gnome-b72673c9fbc860c63a360695cab90835fb98a7d6.tar.zst
freebsd-ports-gnome-b72673c9fbc860c63a360695cab90835fb98a7d6.zip
Remove hardcoded i386 strings in plist to fix plist for amd64.
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-hmake/Makefile10
-rw-r--r--devel/hs-hmake/pkg-plist16
2 files changed, 17 insertions, 9 deletions
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index a37a8ab3e8df..9fec2bc6b2d1 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -27,6 +27,14 @@ HAS_CONFIGURE= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
USE_GMAKE= YES
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+PLIST_SUB+= ARCH=ix86
+.elif ${ARCH} == "amd64"
+PLIST_SUB+= ARCH=amd64
+.endif
+
do-install:
# cheat a bit, otherwise LIBDIR gets clobbered
(cd ${WRKSRC} && ./configure --install)
@@ -38,4 +46,4 @@ MAN1= hmake.1
CONFLICTS= nhc98-[0-9]*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/hs-hmake/pkg-plist b/devel/hs-hmake/pkg-plist
index 17ed5ece278f..6cbfd8ae1ca1 100644
--- a/devel/hs-hmake/pkg-plist
+++ b/devel/hs-hmake/pkg-plist
@@ -3,12 +3,12 @@ bin/hi
bin/hmake
bin/hmake-config
bin/runhs
-lib/hmake/ix86-FreeBSD/HInteractive
-lib/hmake/ix86-FreeBSD/MkProg
-lib/hmake/ix86-FreeBSD/Older
-lib/hmake/ix86-FreeBSD/config
-lib/hmake/ix86-FreeBSD/MkConfig
-lib/hmake/ix86-FreeBSD/hmakerc
-lib/hmake/ix86-FreeBSD/runhs
-@dirrm lib/hmake/ix86-FreeBSD
+lib/hmake/%%ARCH%%-FreeBSD/HInteractive
+lib/hmake/%%ARCH%%-FreeBSD/MkProg
+lib/hmake/%%ARCH%%-FreeBSD/Older
+lib/hmake/%%ARCH%%-FreeBSD/config
+lib/hmake/%%ARCH%%-FreeBSD/MkConfig
+lib/hmake/%%ARCH%%-FreeBSD/hmakerc
+lib/hmake/%%ARCH%%-FreeBSD/runhs
+@dirrm lib/hmake/%%ARCH%%-FreeBSD
@dirrm lib/hmake