aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-14 20:05:42 +0800
committervs <vs@FreeBSD.org>2005-10-14 20:05:42 +0800
commitb7469294e16e9729a3f91c9d60eeb97bffff7345 (patch)
tree4d50a6563c93fb5f3de1493d2751961f36dd4559 /devel
parent219cee8312ad79934aaf8a05f2139964a1ac2d89 (diff)
downloadfreebsd-ports-gnome-b7469294e16e9729a3f91c9d60eeb97bffff7345.tar.gz
freebsd-ports-gnome-b7469294e16e9729a3f91c9d60eeb97bffff7345.tar.zst
freebsd-ports-gnome-b7469294e16e9729a3f91c9d60eeb97bffff7345.zip
Fix breakage of ccscript on 4.x by lifting requisite commoncpp to gcc 3.4
(and track this for ccaudio which also uses commoncpp)
Diffstat (limited to 'devel')
-rw-r--r--devel/commoncpp/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index d9da8a23055e..852a83647b12 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -25,7 +25,8 @@ CONFIGURE_ARGS= --without-libxml2
USE_GETOPT_LONG= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_DOXYGEN=no
INSTALLS_SHLIB= yes
@@ -35,4 +36,7 @@ INFO= commoncpp2
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/autoconf
+
.include <bsd.port.mk>