aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2008-04-16 21:58:41 +0800
committerlth <lth@FreeBSD.org>2008-04-16 21:58:41 +0800
commitb7b1ecb39778ff87f98df43dc9b4cad3b3ce3819 (patch)
treedd594319e7433629191057ecc13019d6caabbbab /devel
parent5a3f14f69d9d6581184dc092e283ad92ef77840b (diff)
downloadfreebsd-ports-gnome-b7b1ecb39778ff87f98df43dc9b4cad3b3ce3819.tar.gz
freebsd-ports-gnome-b7b1ecb39778ff87f98df43dc9b4cad3b3ce3819.tar.zst
freebsd-ports-gnome-b7b1ecb39778ff87f98df43dc9b4cad3b3ce3819.zip
Add p5-Test-Block 0.11, specify fine granularity test plans.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Block/Makefile26
-rw-r--r--devel/p5-Test-Block/distinfo3
-rw-r--r--devel/p5-Test-Block/pkg-descr5
-rw-r--r--devel/p5-Test-Block/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b62a0efc403c..80c2958c3dd8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1644,6 +1644,7 @@
SUBDIR += p5-Test-Assertions
SUBDIR += p5-Test-Base
SUBDIR += p5-Test-Benchmark
+ SUBDIR += p5-Test-Block
SUBDIR += p5-Test-Class
SUBDIR += p5-Test-ClassAPI
SUBDIR += p5-Test-Cmd
diff --git a/devel/p5-Test-Block/Makefile b/devel/p5-Test-Block/Makefile
new file mode 100644
index 000000000000..082992583e13
--- /dev/null
+++ b/devel/p5-Test-Block/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Test-Block
+# Date created: 16 April 2008
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Block
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Specify fine granularity test plans
+
+BUILD_DEPENDS= p5-Test-Exception>=0.15:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Simple>=0.47:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= 5.6.1+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Block.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Block/distinfo b/devel/p5-Test-Block/distinfo
new file mode 100644
index 000000000000..11cae420b880
--- /dev/null
+++ b/devel/p5-Test-Block/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Block-0.11.tar.gz) = 386a722947f2c77f6157d1dea0338e35
+SHA256 (Test-Block-0.11.tar.gz) = 1d836fdeb1e4082ccec6b46b9231b3f16004611a2b3e63ec51dc02016e4587b4
+SIZE (Test-Block-0.11.tar.gz) = 7568
diff --git a/devel/p5-Test-Block/pkg-descr b/devel/p5-Test-Block/pkg-descr
new file mode 100644
index 000000000000..28a068525e70
--- /dev/null
+++ b/devel/p5-Test-Block/pkg-descr
@@ -0,0 +1,5 @@
+This module allows you to specify the number of expected tests at
+a finer level of granularity than an entire test script. It is built
+with Test::Builder and plays happily with Test::More and friends.
+
+WWW: http://search.cpan.org/dist/Test-Block/
diff --git a/devel/p5-Test-Block/pkg-plist b/devel/p5-Test-Block/pkg-plist
new file mode 100644
index 000000000000..d306a488aa3e
--- /dev/null
+++ b/devel/p5-Test-Block/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Block.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Block/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Block
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test