aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-04-17 01:05:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-04-17 01:05:55 +0800
commitb7ea729f56a4de21cd27a501729d172058c02567 (patch)
tree9980189a4ccc8198012ded973b4c4e13cc1c05f2 /devel
parent971ad5c3258fb364e6e33ad5ee00f2c568cd3d00 (diff)
downloadfreebsd-ports-gnome-b7ea729f56a4de21cd27a501729d172058c02567.tar.gz
freebsd-ports-gnome-b7ea729f56a4de21cd27a501729d172058c02567.tar.zst
freebsd-ports-gnome-b7ea729f56a4de21cd27a501729d172058c02567.zip
- Add p5-Module-Build-Tiny 0.017
Many Perl distributions use a Build.PL file instead of a Makefile.PL file to drive distribution configuration, build, test and installation. Traditionally, Build.PL uses Module::Build as the underlying build system. This module provides a simple, lightweight, drop-in replacement. Whereas Module::Build has over 6,700 lines of code; this module has less than 70, yet supports the features needed by most pure-Perl distributions. WWW: http://search.cpan.org/dist/Module-Build-Tiny/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Module-Build-Tiny/Makefile34
-rw-r--r--devel/p5-Module-Build-Tiny/distinfo2
-rw-r--r--devel/p5-Module-Build-Tiny/pkg-descr9
-rw-r--r--devel/p5-Module-Build-Tiny/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ecdabd26efb8..a8394a19d70e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2241,6 +2241,7 @@
SUBDIR += p5-Module-Build
SUBDIR += p5-Module-Build-Convert
SUBDIR += p5-Module-Build-Kwalitee
+ SUBDIR += p5-Module-Build-Tiny
SUBDIR += p5-Module-CPANTS-Analyse
SUBDIR += p5-Module-CPANfile
SUBDIR += p5-Module-CheckDeps
diff --git a/devel/p5-Module-Build-Tiny/Makefile b/devel/p5-Module-Build-Tiny/Makefile
new file mode 100644
index 000000000000..0a5731111f8e
--- /dev/null
+++ b/devel/p5-Module-Build-Tiny/Makefile
@@ -0,0 +1,34 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Module-Build-Tiny
+PORTVERSION= 0.017
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tiny replacement for Module::Build
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-ExtUtils-Config>=0.003:${PORTSDIR}/devel/p5-ExtUtils-Config \
+ p5-ExtUtils-Helpers>=0.016:${PORTSDIR}/devel/p5-ExtUtils-Helpers \
+ p5-ExtUtils-InstallPaths>=0.002:${PORTSDIR}/devel/p5-ExtUtils-InstallPaths
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Module::Build::Tiny.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-CPAN-Meta>=0:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-JSON-PP>=2:${PORTSDIR}/converters/p5-JSON-PP
+RUN_DEPENDS+= p5-CPAN-Meta>=0:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-JSON-PP>=2:${PORTSDIR}/converters/p5-JSON-PP
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Module-Build-Tiny/distinfo b/devel/p5-Module-Build-Tiny/distinfo
new file mode 100644
index 000000000000..51caa45b8fc4
--- /dev/null
+++ b/devel/p5-Module-Build-Tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Module-Build-Tiny-0.017.tar.gz) = abbd2f98b5414508505d559e94cd12c948eb4f59b8f8a08b8b847da74c8b0aca
+SIZE (Module-Build-Tiny-0.017.tar.gz) = 18392
diff --git a/devel/p5-Module-Build-Tiny/pkg-descr b/devel/p5-Module-Build-Tiny/pkg-descr
new file mode 100644
index 000000000000..db73045d40e2
--- /dev/null
+++ b/devel/p5-Module-Build-Tiny/pkg-descr
@@ -0,0 +1,9 @@
+Many Perl distributions use a Build.PL file instead of a Makefile.PL file to
+drive distribution configuration, build, test and installation. Traditionally,
+Build.PL uses Module::Build as the underlying build system. This module provides
+a simple, lightweight, drop-in replacement.
+
+Whereas Module::Build has over 6,700 lines of code; this module has less than
+70, yet supports the features needed by most pure-Perl distributions.
+
+WWW: http://search.cpan.org/dist/Module-Build-Tiny/
diff --git a/devel/p5-Module-Build-Tiny/pkg-plist b/devel/p5-Module-Build-Tiny/pkg-plist
new file mode 100644
index 000000000000..1625679b1ff4
--- /dev/null
+++ b/devel/p5-Module-Build-Tiny/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Module/Build/Tiny.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Build/Tiny/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Build/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Build
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module
+@dirrmtry %%SITE_PERL%%/Module/Build
+@dirrmtry %%SITE_PERL%%/Module