aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-11-29 22:49:24 +0800
committerstas <stas@FreeBSD.org>2006-11-29 22:49:24 +0800
commitb831d02d53a971e1a9d0c4e9cf949c661f518735 (patch)
tree2f89f7f13d012806fdf40bdba2ce0838760c506c /devel
parentfd91db96f71de9aa27d7773cf57c7f12d2cd7be6 (diff)
downloadfreebsd-ports-gnome-b831d02d53a971e1a9d0c4e9cf949c661f518735.tar.gz
freebsd-ports-gnome-b831d02d53a971e1a9d0c4e9cf949c661f518735.tar.zst
freebsd-ports-gnome-b831d02d53a971e1a9d0c4e9cf949c661f518735.zip
- Add port for devel/fga
FGA is a simple yet powerful implementation of a general genetic algorithm, and provides many types of crossover and selection procedures. It is suitable to solve mathematical problems such as combinatorical optimization ones, as well as to build artificial life simulations.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/fga/Makefile42
-rw-r--r--devel/fga/distinfo3
-rw-r--r--devel/fga/pkg-descr14
-rw-r--r--devel/fga/pkg-plist12
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 73912e1f6929..49fedeb4700c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -285,6 +285,7 @@
SUBDIR += fastdep
SUBDIR += fc++
SUBDIR += ffcall
+ SUBDIR += fga
SUBDIR += fhist
SUBDIR += fib
SUBDIR += fistgen
diff --git a/devel/fga/Makefile b/devel/fga/Makefile
new file mode 100644
index 000000000000..0979b4020123
--- /dev/null
+++ b/devel/fga/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: fga
+# Date created: 2006-11-29
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= fga
+PORTVERSION= 0.9
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Fast Genetic Algorithm library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
+EXAMPLES= graph_gen maxbit_mt maxbit_st tsp tsp_bf
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/fga.hpp ${PREFIX}/include
+ ${INSTALL_PROGRAM} ${EXAMPLES:S,^,${WRKSRC}/,} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/,:S,$,.cpp,} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/fga/distinfo b/devel/fga/distinfo
new file mode 100644
index 000000000000..1554d4952c33
--- /dev/null
+++ b/devel/fga/distinfo
@@ -0,0 +1,3 @@
+MD5 (fga-0.9.tar.gz) = c4195e23c1c4c52a8ade4752602c8245
+SHA256 (fga-0.9.tar.gz) = 9f08fe65460cb3805d200851e4b001df31e2441d4e82bd57f562a796a2572a26
+SIZE (fga-0.9.tar.gz) = 133433
diff --git a/devel/fga/pkg-descr b/devel/fga/pkg-descr
new file mode 100644
index 000000000000..65eb8068e577
--- /dev/null
+++ b/devel/fga/pkg-descr
@@ -0,0 +1,14 @@
+FGA is a simple yet powerful implementation of a general genetic algorithm, and
+provides many types of crossover and selection procedures.
+
+It is suitable to solve mathematical problems such as combinatorical
+optimization ones, as well as to build artificial life simulations.
+
+Written in C++, the library is released under the terms of the GNU Lesser
+General Public License, and it's easy to incorporate in other applications.
+
+A parallel version of the algorithm (using POSIX threads) is included in order
+to take advantage of multi-processor environments.
+
+Author: Alessandro Presta <alessandro.presta@gmail.com>
+WWW: http://fga.sourceforge.net/
diff --git a/devel/fga/pkg-plist b/devel/fga/pkg-plist
new file mode 100644
index 000000000000..3c343db0827a
--- /dev/null
+++ b/devel/fga/pkg-plist
@@ -0,0 +1,12 @@
+bin/graph_gen
+bin/maxbit_mt
+bin/maxbit_st
+bin/tsp
+bin/tsp_bf
+include/fga.hpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/graph_gen.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/maxbit_mt.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/maxbit_st.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/tsp.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/tsp_bf.cpp
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%