aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-06-16 18:18:16 +0800
committerkris <kris@FreeBSD.org>2002-06-16 18:18:16 +0800
commitb9d1b9a8ea3d1b63765dacbe0ca2c1b6c53b898b (patch)
tree70be7ed5e4367a76cee76803a59cd77e5960617c /devel
parentb1d513c4975e76d734b9fe990d7f72543942a47e (diff)
downloadfreebsd-ports-gnome-b9d1b9a8ea3d1b63765dacbe0ca2c1b6c53b898b.tar.gz
freebsd-ports-gnome-b9d1b9a8ea3d1b63765dacbe0ca2c1b6c53b898b.tar.zst
freebsd-ports-gnome-b9d1b9a8ea3d1b63765dacbe0ca2c1b6c53b898b.zip
Fix build on current
Diffstat (limited to 'devel')
-rw-r--r--devel/libshhmsg/files/Makefile.lib3
-rw-r--r--devel/libshhopt/files/Makefile3
-rw-r--r--devel/libshhopt/files/Makefile.lib3
-rw-r--r--devel/libxalloc/files/Makefile.lib3
4 files changed, 8 insertions, 4 deletions
diff --git a/devel/libshhmsg/files/Makefile.lib b/devel/libshhmsg/files/Makefile.lib
index 29258a653b72..17e3fe8ffec3 100644
--- a/devel/libshhmsg/files/Makefile.lib
+++ b/devel/libshhmsg/files/Makefile.lib
@@ -9,7 +9,8 @@ NOPROFILE= yes
NOOBJ= yes
INCS= shhmsg.h
-INCDIR= ${PREFIX}/include
+INCSDIR=${PREFIX}/include
+INCDIR= ${PREFIX} # for 4.x bsd.lib.mk
CFLAGS+= -DHAVE_STRERROR
diff --git a/devel/libshhopt/files/Makefile b/devel/libshhopt/files/Makefile
index 7d992264e100..0cc2ce8d365d 100644
--- a/devel/libshhopt/files/Makefile
+++ b/devel/libshhopt/files/Makefile
@@ -2,7 +2,8 @@
PREFIX = /usr/local
LIBDIR = $(PREFIX)/lib
-INCDIR = $(PREFIX)/include
+INCSDIR = $(PREFIX)/include
+INCDIR = $(INCSDIR) # for 4.x bsd.lib.mk
example:
$(CC) -o example example.c -I$(INCDIR) -L$(LIBDIR) -lshhopt
diff --git a/devel/libshhopt/files/Makefile.lib b/devel/libshhopt/files/Makefile.lib
index 37bf6c5cc6b6..e89e2a2dd3d1 100644
--- a/devel/libshhopt/files/Makefile.lib
+++ b/devel/libshhopt/files/Makefile.lib
@@ -9,7 +9,8 @@ NOPROFILE= yes
NOOBJ= yes
INCS= shhopt.h
-INCDIR= ${PREFIX}/include
+INCSDIR=${PREFIX}/include
+INCDIR= ${INCSDIR} # for 4.x bsd.lib.mk
SRCS= shhopt.c
diff --git a/devel/libxalloc/files/Makefile.lib b/devel/libxalloc/files/Makefile.lib
index 9c88a7e8a043..cc30ba4d5ffa 100644
--- a/devel/libxalloc/files/Makefile.lib
+++ b/devel/libxalloc/files/Makefile.lib
@@ -9,7 +9,8 @@ NOPROFILE= yes
NOOBJ= yes
INCS= xalloc.h
-INCDIR= ${PREFIX}/include
+INCSDIR=${PREFIX}/include
+INCDIR= ${INCSDIR} # for 4.x bsd.lib.mk
SRCS= xalloc.c xmalloc.c xcalloc.c xrealloc.c xstrdup.c