aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-20 16:56:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-20 16:56:55 +0800
commitbaa4c4f4a0e07c4d97552f8d13c14a7c62e687f5 (patch)
treed201d28e0d9769842f577a37d1b408d86bac3831 /devel
parentc9d6d342850a049d11915722dd5ca2af481cf03a (diff)
downloadfreebsd-ports-gnome-baa4c4f4a0e07c4d97552f8d13c14a7c62e687f5.tar.gz
freebsd-ports-gnome-baa4c4f4a0e07c4d97552f8d13c14a7c62e687f5.tar.zst
freebsd-ports-gnome-baa4c4f4a0e07c4d97552f8d13c14a7c62e687f5.zip
- Add p5-Tree-RedBlack 0.5
Tree::RedBlack is a perl implementation of the Red/Black tree algorithm found in the book "Algorithms", by Cormen, Leiserson & Rivest (more commonly known as "CLR" or "The White Book"). A Red/Black tree is a binary tree which remains "balanced"- that is, the longest length from root to a node is at most one more than the shortest such length. It is fairly efficient; no operation takes more than O(lg(n)) time. A Tree::RedBlack object supports the following methods: new(), root(), cmp(&), insert($, $), delete($), find($), node($), min() and max(). WWW: http://search.cpan.org/dist/Tree-RedBlack/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tree-RedBlack/Makefile23
-rw-r--r--devel/p5-Tree-RedBlack/distinfo2
-rw-r--r--devel/p5-Tree-RedBlack/pkg-descr11
-rw-r--r--devel/p5-Tree-RedBlack/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 35d945d2b85e..3c6f562014c2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2518,6 +2518,7 @@
SUBDIR += p5-Tree-Node
SUBDIR += p5-Tree-Parser
SUBDIR += p5-Tree-R
+ SUBDIR += p5-Tree-RedBlack
SUBDIR += p5-Tree-Simple
SUBDIR += p5-Tree-Simple-View
SUBDIR += p5-Tree-Simple-VisitorFactory
diff --git a/devel/p5-Tree-RedBlack/Makefile b/devel/p5-Tree-RedBlack/Makefile
new file mode 100644
index 000000000000..029bce9d6134
--- /dev/null
+++ b/devel/p5-Tree-RedBlack/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Tree-RedBlack
+# Date created: 2011-09-11
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tree-RedBlack
+PORTVERSION= 0.5
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Perl implementation of Red/Black tree, a type of balanced tree
+
+PERL_CONFIGURE= yes
+
+MAN3= Tree::Node.3 \
+ Tree::RedBlack.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Tree-RedBlack/distinfo b/devel/p5-Tree-RedBlack/distinfo
new file mode 100644
index 000000000000..cfbcc2757d8e
--- /dev/null
+++ b/devel/p5-Tree-RedBlack/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Tree-RedBlack-0.5.tar.gz) = 406c06d21a5d38314b05e25516ee5942ebecd8a5c40b43a23ed4170fab3b657a
+SIZE (Tree-RedBlack-0.5.tar.gz) = 5734
diff --git a/devel/p5-Tree-RedBlack/pkg-descr b/devel/p5-Tree-RedBlack/pkg-descr
new file mode 100644
index 000000000000..9090242c0f4f
--- /dev/null
+++ b/devel/p5-Tree-RedBlack/pkg-descr
@@ -0,0 +1,11 @@
+Tree::RedBlack is a perl implementation of the Red/Black tree algorithm found in
+the book "Algorithms", by Cormen, Leiserson & Rivest (more commonly known as
+"CLR" or "The White Book"). A Red/Black tree is a binary tree which remains
+"balanced"- that is, the longest length from root to a node is at most one more
+than the shortest such length. It is fairly efficient; no operation takes more
+than O(lg(n)) time.
+
+A Tree::RedBlack object supports the following methods: new(), root(), cmp(&),
+insert($, $), delete($), find($), node($), min() and max().
+
+WWW: http://search.cpan.org/dist/Tree-RedBlack/
diff --git a/devel/p5-Tree-RedBlack/pkg-plist b/devel/p5-Tree-RedBlack/pkg-plist
new file mode 100644
index 000000000000..487895d3a55a
--- /dev/null
+++ b/devel/p5-Tree-RedBlack/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Tree/RedBlack.pm
+%%SITE_PERL%%/Tree/RedBlack/Node.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/RedBlack/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/RedBlack
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree
+@dirrm %%SITE_PERL%%/Tree/RedBlack
+@dirrmtry %%SITE_PERL%%/Tree