aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-07-07 15:18:19 +0800
committergahr <gahr@FreeBSD.org>2011-07-07 15:18:19 +0800
commitbbd3b02c6591f34396318eb7dedf059f6b04c173 (patch)
tree04104bbd5d1d8014f2f796efeec2d0e927b5a8ff /devel
parent89b5030f33955b8747449d88b2959254fa7913f8 (diff)
downloadfreebsd-ports-gnome-bbd3b02c6591f34396318eb7dedf059f6b04c173.tar.gz
freebsd-ports-gnome-bbd3b02c6591f34396318eb7dedf059f6b04c173.tar.zst
freebsd-ports-gnome-bbd3b02c6591f34396318eb7dedf059f6b04c173.zip
- fix runtime path of DATADIR in source code
- bump PORTREVISION
Diffstat (limited to 'devel')
-rw-r--r--devel/gdcm/Makefile2
-rw-r--r--devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index d670185b5df5..b55de107142d 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gdcm
PORTVERSION= ${GDCM_MAJ}.${GDCM_MIN}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/gdcm/gdcm%202.x/GDCM%20${PORTVERSION}
diff --git a/devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx b/devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx
new file mode 100644
index 000000000000..eccf73102831
--- /dev/null
+++ b/devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx
@@ -0,0 +1,11 @@
+--- Source/DataDictionary/gdcmGlobal.cxx.orig 2011-07-07 09:11:27.000000000 +0200
++++ Source/DataDictionary/gdcmGlobal.cxx 2011-07-07 09:11:56.000000000 +0200
+@@ -45,7 +45,7 @@
+ void LoadDefaultPaths()
+ {
+ assert( RessourcePaths.empty() );
+- const char filename2[] = GDCM_CMAKE_INSTALL_PREFIX "/" GDCM_INSTALL_DATA_DIR "/XML/";
++ const char filename2[] = GDCM_INSTALL_DATA_DIR "/XML/";
+ RessourcePaths.push_back( filename2 );
+ const char *curprocfn = System::GetCurrentProcessFileName();
+ if( curprocfn )