aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-02-19 04:17:19 +0800
committerkwm <kwm@FreeBSD.org>2014-02-19 04:17:19 +0800
commitbf043c97569c7168c72d8afccc7844008e59f4db (patch)
tree4cc5b109bbe5a7efbbccb608086af31502982bf4 /devel
parente0cb9a06c3bdffc0e629456e71e925b2bcdd8aff (diff)
downloadfreebsd-ports-gnome-bf043c97569c7168c72d8afccc7844008e59f4db.tar.gz
freebsd-ports-gnome-bf043c97569c7168c72d8afccc7844008e59f4db.tar.zst
freebsd-ports-gnome-bf043c97569c7168c72d8afccc7844008e59f4db.zip
Drop e-d-s support, new version of e-d-s from gnome3 is not compatible.
While here use USES=gmake, stagify, drop desktop-file-utils usage, strip.
Diffstat (limited to 'devel')
-rw-r--r--devel/giggle/Makefile22
-rw-r--r--devel/giggle/pkg-plist2
2 files changed, 6 insertions, 18 deletions
diff --git a/devel/giggle/Makefile b/devel/giggle/Makefile
index 322702e8989d..07b4fc4562ae 100644
--- a/devel/giggle/Makefile
+++ b/devel/giggle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= giggle
PORTVERSION= 0.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= GNOME
@@ -14,31 +14,24 @@ BUILD_DEPENDS= git:${PORTSDIR}/devel/git \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS= git:${PORTSDIR}/devel/git
-OPTIONS_DEFINE= EDS VTE
-OPTIONS_DEFAULT= EDS VTE
-EDS_DESC= Evolution Data Server support
+OPTIONS_DEFINE= VTE
+OPTIONS_DEFAULT= VTE
VTE_DESC= Terminal Widget
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_BZIP2= yes
USE_GNOME= glib20 gtk20 gtksourceview2 libglade2
-USES= gettext pkgconfig
+USES= gettext gmake pkgconfig
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl `pkg-config -libs gmodule-2.0`
+INSTALL_TARGET= install-strip
PLIST_SUB+= GIGGLE_VER=${PORTVERSION}
+CONFIGURE_ARGS+= --disable-evolution-data-server
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MEDS}
-USE_GNOME+= evolutiondataserver
-.else
-CONFIGURE_ARGS+= --disable-evolution-data-server
-.endif
-
.if ${PORT_OPTIONS:MVTE}
USE_GNOME+= vte
PLIST_SUB+= VTE=""
@@ -47,7 +40,4 @@ CONFIGURE_ARGS+= --disable-terminal
PLIST_SUB+= VTE="@comment "
.endif
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/devel/giggle/pkg-plist b/devel/giggle/pkg-plist
index b855dc0b62de..b031908a4363 100644
--- a/devel/giggle/pkg-plist
+++ b/devel/giggle/pkg-plist
@@ -78,5 +78,3 @@ share/locale/zh_CN/LC_MESSAGES/giggle.mo
@dirrm include/giggle/libgiggle-git
@dirrm include/giggle/libgiggle
@dirrm include/giggle
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true