aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-09 23:46:55 +0800
committermiwi <miwi@FreeBSD.org>2006-12-09 23:46:55 +0800
commitc06905f0c5331c5f4f46191325102928cd8eaf98 (patch)
treed2a199aab3f84714a3a3b9481ce670c438dfdd3d /devel
parent6a5c4e591e1f73ecb4fcf798c0af960f0f661b7e (diff)
downloadfreebsd-ports-gnome-c06905f0c5331c5f4f46191325102928cd8eaf98.tar.gz
freebsd-ports-gnome-c06905f0c5331c5f4f46191325102928cd8eaf98.tar.zst
freebsd-ports-gnome-c06905f0c5331c5f4f46191325102928cd8eaf98.zip
AnyEvent provides an identical interface to multiple event loops.
This allows module authors to utilise an event loop without forcing module users to use the same event loop (as only a single event loop can coexist peacefully at any one time). The interface itself is vaguely similar but not identical to the Event module. On the first call of any method, the module tries to detect the currently loaded event loop by probing wether any of the following modules is loaded: Coro::Event, Event, Glib, Tk. The first one found is used. If none is found, the module tries to load these modules in the order given. The first one that could be successfully loaded will be used. If still none could be found, AnyEvent will fall back to a pure-perl event loop, which is also not very efficient. WWW: http://search.cpan.org/dist/AnyEvent/ Noted: For index unbreak :( PR: ports/106527 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-AnyEvent/Makefile28
-rw-r--r--devel/p5-AnyEvent/distinfo3
-rw-r--r--devel/p5-AnyEvent/pkg-descr17
-rw-r--r--devel/p5-AnyEvent/pkg-plist11
5 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7e129b46c5c6..a3655c4f3d4b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -796,6 +796,7 @@
SUBDIR += p5-Alias
SUBDIR += p5-Alzabo
SUBDIR += p5-Alzabo-GUI-Mason
+ SUBDIR += p5-AnyEvent
SUBDIR += p5-App-CLI
SUBDIR += p5-App-Cache
SUBDIR += p5-App-Info
diff --git a/devel/p5-AnyEvent/Makefile b/devel/p5-AnyEvent/Makefile
new file mode 100644
index 000000000000..7b0b12cc58e8
--- /dev/null
+++ b/devel/p5-AnyEvent/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-AnyEvent
+# Date created: 2006-12-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent
+PORTVERSION= 2.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/ML/MLEHMANN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Provide framework for multiple event loops
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/p5-AnyEvent/distinfo b/devel/p5-AnyEvent/distinfo
new file mode 100644
index 000000000000..b04a6fbba026
--- /dev/null
+++ b/devel/p5-AnyEvent/distinfo
@@ -0,0 +1,3 @@
+MD5 (AnyEvent-2.1.tar.gz) = 048a183e5c3154f8d7d0b16888ffe07b
+SHA256 (AnyEvent-2.1.tar.gz) = f0d8d6094f5dc6c14912ac79e1136413223671f3cda6bdebf81963d963f08249
+SIZE (AnyEvent-2.1.tar.gz) = 11121
diff --git a/devel/p5-AnyEvent/pkg-descr b/devel/p5-AnyEvent/pkg-descr
new file mode 100644
index 000000000000..25ef1d37bd42
--- /dev/null
+++ b/devel/p5-AnyEvent/pkg-descr
@@ -0,0 +1,17 @@
+AnyEvent provides an identical interface to multiple event loops.
+This allows module authors to utilise an event loop without forcing
+module users to use the same event loop (as only a single event loop
+can coexist peacefully at any one time).
+
+The interface itself is vaguely similar but not identical to the Event
+module.
+
+On the first call of any method, the module tries to detect the
+currently loaded event loop by probing wether any of the following
+modules is loaded: Coro::Event, Event, Glib, Tk. The first one found
+is used. If none is found, the module tries to load these modules in
+the order given. The first one that could be successfully loaded will
+be used. If still none could be found, AnyEvent will fall back to a
+pure-perl event loop, which is also not very efficient.
+
+WWW: http://search.cpan.org/dist/AnyEvent/
diff --git a/devel/p5-AnyEvent/pkg-plist b/devel/p5-AnyEvent/pkg-plist
new file mode 100644
index 000000000000..60bce583781a
--- /dev/null
+++ b/devel/p5-AnyEvent/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/.packlist
+%%SITE_PERL%%/AnyEvent.pm
+%%SITE_PERL%%/AnyEvent/Impl/Coro.pm
+%%SITE_PERL%%/AnyEvent/Impl/Event.pm
+%%SITE_PERL%%/AnyEvent/Impl/Glib.pm
+%%SITE_PERL%%/AnyEvent/Impl/Perl.pm
+%%SITE_PERL%%/AnyEvent/Impl/Tk.pm
+@dirrmtry %%SITE_PERL%%/AnyEvent/Impl
+@dirrmtry %%SITE_PERL%%/AnyEvent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent