aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2013-05-03 06:21:24 +0800
committermi <mi@FreeBSD.org>2013-05-03 06:21:24 +0800
commitc09de2212ad0abcca8f582b4656e532ae6a7c103 (patch)
treecafedb0dafeb2c72188206bb55f03f10cc0035ce /devel
parent07585525c38ed5ebb896012f37c90a16f2d67f4e (diff)
downloadfreebsd-ports-gnome-c09de2212ad0abcca8f582b4656e532ae6a7c103.tar.gz
freebsd-ports-gnome-c09de2212ad0abcca8f582b4656e532ae6a7c103.tar.zst
freebsd-ports-gnome-c09de2212ad0abcca8f582b4656e532ae6a7c103.zip
When BOOST_TOOLSET is "gcc", the actual compiler can be anything from g++ to g++48.
Make sure, the ${CXX} specified is used by the port, rather than the default g++. Tested with: g++48 Approved by: bapt
Diffstat (limited to 'devel')
-rw-r--r--devel/boost-all/compiled.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index 730673dd1bdf..50f7e7ef72ad 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -58,3 +58,6 @@ BJAM_ARGS+= inlining=full
post-patch:
@${REINPLACE_CMD} -e 's|${PORTVERSION}|${BOOST_SHARED_LIB_VER}|g' \
${WRKSRC}/Jamroot
+.if ${BOOST_TOOLSET} == gcc
+ @${ECHO} "using gcc : : ${CXX} ;" >> ${WRKSRC}/tools/build/v2/user-config.jam
+.endif