aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-06-11 20:01:07 +0800
committersobomax <sobomax@FreeBSD.org>2001-06-11 20:01:07 +0800
commitc13d39693a7edb8b9a0a03dfd99bc0d472a006c6 (patch)
tree55e766ed8049d878f22a8866dcfc60c5be9549ef /devel
parentdb8f59017a792b2e935308f4e737e534c689526e (diff)
downloadfreebsd-ports-gnome-c13d39693a7edb8b9a0a03dfd99bc0d472a006c6.tar.gz
freebsd-ports-gnome-c13d39693a7edb8b9a0a03dfd99bc0d472a006c6.tar.zst
freebsd-ports-gnome-c13d39693a7edb8b9a0a03dfd99bc0d472a006c6.zip
Install documentation and examples.
Submitted by: "Bryan K. Ogawa" <bko@idiom.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/py-game/Makefile8
-rw-r--r--devel/py-game/pkg-plist89
2 files changed, 97 insertions, 0 deletions
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index df4d28cad7cf..40fe76af559f 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -43,5 +43,13 @@ do-build:
do-install:
@${SETUP_CMD} setup.py install
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/py-game
+ ${TAR} -C ${WRKSRC}/examples -cf - . | \
+ ${TAR} --unlink -C ${PREFIX}/share/examples/py-game -xf -
+ ${MKDIR} ${PREFIX}/share/doc/py-game
+ ${TAR} -C ${WRKSRC}/docs -cf - . | \
+ ${TAR} --unlink -C ${PREFIX}/share/doc/py-game -xf -
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/py-game/pkg-plist b/devel/py-game/pkg-plist
index 718e33207347..a59725958c15 100644
--- a/devel/py-game/pkg-plist
+++ b/devel/py-game/pkg-plist
@@ -32,5 +32,94 @@ lib/%%PYTHON_VERSION%%/site-packages/pygame/surflock.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/time.so
lib/%%PYTHON_VERSION%%/site-packages/pygame/version.py
lib/%%PYTHON_VERSION%%/site-packages/pygame/version.pyc
+%%PORTDOCS%%share/doc/py-game/LGPL
+%%PORTDOCS%%share/doc/py-game/fullinstall.txt
+%%PORTDOCS%%share/doc/py-game/index.html
+%%PORTDOCS%%share/doc/py-game/init.txt
+%%PORTDOCS%%share/doc/py-game/ref/CD.html
+%%PORTDOCS%%share/doc/py-game/ref/Channel.html
+%%PORTDOCS%%share/doc/py-game/ref/Font.html
+%%PORTDOCS%%share/doc/py-game/ref/Joystick.html
+%%PORTDOCS%%share/doc/py-game/ref/Rect.html
+%%PORTDOCS%%share/doc/py-game/ref/Sound.html
+%%PORTDOCS%%share/doc/py-game/ref/Surface.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_UserRect.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_cdrom.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_constants.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_cursors.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_display.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_draw.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_event.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_font.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_image.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_joystick.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_key.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_mixer.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_mixer_music.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_mouse.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_surfarray.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_time.html
+%%PORTDOCS%%share/doc/py-game/ref/pygame_version.html
+%%PORTDOCS%%share/doc/py-game/tut/ChimpLineByLine.html
+%%PORTDOCS%%share/doc/py-game/tut/DisplayModes.html
+%%PORTDOCS%%share/doc/py-game/tut/Executable.html
+%%PORTDOCS%%share/doc/py-game/tut/SurfarrayIntro.html
+%%PORTDOCS%%share/doc/py-game/tut/allblack.jpg
+%%PORTDOCS%%share/doc/py-game/tut/chimp.py.html
+%%PORTDOCS%%share/doc/py-game/tut/chimpshot.gif
+%%PORTDOCS%%share/doc/py-game/tut/flipped.jpg
+%%PORTDOCS%%share/doc/py-game/tut/imgarray.jpg
+%%PORTDOCS%%share/doc/py-game/tut/redimg.jpg
+%%PORTDOCS%%share/doc/py-game/tut/scaledown.jpg
+%%PORTDOCS%%share/doc/py-game/tut/scaleup.jpg
+%%PORTDOCS%%share/doc/py-game/tut/soften.jpg
+%%PORTDOCS%%share/doc/py-game/tut/striped.jpg
+%%PORTDOCS%%share/doc/py-game/tut/xfade.jpg
+%%PORTDOCS%%share/doc/py-game/util/doclate.html
+%%PORTDOCS%%share/doc/py-game/util/listlate.html
+%%PORTDOCS%%share/doc/py-game/util/makedocs.py
+%%PORTDOCS%%share/doc/py-game/util/pagelate.html
+%%PORTDOCS%%share/examples/py-game/Readme.txt
+%%PORTDOCS%%share/examples/py-game/aliens.py
+%%PORTDOCS%%share/examples/py-game/arraydemo.py
+%%PORTDOCS%%share/examples/py-game/chimp.py
+%%PORTDOCS%%share/examples/py-game/data/alien1.gif
+%%PORTDOCS%%share/examples/py-game/data/alien2.gif
+%%PORTDOCS%%share/examples/py-game/data/alien3.gif
+%%PORTDOCS%%share/examples/py-game/data/arraydemo.jpg
+%%PORTDOCS%%share/examples/py-game/data/background.gif
+%%PORTDOCS%%share/examples/py-game/data/bomb.gif
+%%PORTDOCS%%share/examples/py-game/data/boom.wav
+%%PORTDOCS%%share/examples/py-game/data/car_door.wav
+%%PORTDOCS%%share/examples/py-game/data/chimp.gif
+%%PORTDOCS%%share/examples/py-game/data/danger.gif
+%%PORTDOCS%%share/examples/py-game/data/explosion1.gif
+%%PORTDOCS%%share/examples/py-game/data/explosion2.gif
+%%PORTDOCS%%share/examples/py-game/data/fist.gif
+%%PORTDOCS%%share/examples/py-game/data/house_lo.wav
+%%PORTDOCS%%share/examples/py-game/data/liquid.gif
+%%PORTDOCS%%share/examples/py-game/data/oldplayer.gif
+%%PORTDOCS%%share/examples/py-game/data/player1.gif
+%%PORTDOCS%%share/examples/py-game/data/player2.gif
+%%PORTDOCS%%share/examples/py-game/data/punch.wav
+%%PORTDOCS%%share/examples/py-game/data/secosmic_lo.wav
+%%PORTDOCS%%share/examples/py-game/data/shot.gif
+%%PORTDOCS%%share/examples/py-game/data/whiff.wav
+%%PORTDOCS%%share/examples/py-game/fonty.py
+%%PORTDOCS%%share/examples/py-game/liquid.py
+%%PORTDOCS%%share/examples/py-game/oldalien.py
+%%PORTDOCS%%share/examples/py-game/sdllogos.zip
+%%PORTDOCS%%share/examples/py-game/sound.py
+%%PORTDOCS%%share/examples/py-game/stars.py
+%%PORTDOCS%%share/examples/py-game/vgrade.py
+%%PORTDOCS%%share/examples/py-game/winaliens.pyw
+%%PORTDOCS%%share/examples/py-game/zipshow.py
+%%PORTDOCS%%@dirrm share/examples/py-game/data
+%%PORTDOCS%%@dirrm share/examples/py-game
+%%PORTDOCS%%@dirrm share/doc/py-game/util
+%%PORTDOCS%%@dirrm share/doc/py-game/tut
+%%PORTDOCS%%@dirrm share/doc/py-game/ref
+%%PORTDOCS%%@dirrm share/doc/py-game
@dirrm lib/%%PYTHON_VERSION%%/site-packages/pygame
@dirrm include/%%PYTHON_VERSION%%/pygame