aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2011-01-08 07:03:35 +0800
committerglarkin <glarkin@FreeBSD.org>2011-01-08 07:03:35 +0800
commitc2b315ad95960dfdbaa58ba2b205dea794861392 (patch)
tree3b3d92dbdd290cd0e05358d6711af3983f0d2a17 /devel
parenta8dde69ccafa4f57d56c04f8cb58d85f162dbfd2 (diff)
downloadfreebsd-ports-gnome-c2b315ad95960dfdbaa58ba2b205dea794861392.tar.gz
freebsd-ports-gnome-c2b315ad95960dfdbaa58ba2b205dea794861392.tar.zst
freebsd-ports-gnome-c2b315ad95960dfdbaa58ba2b205dea794861392.zip
- Fixed a dependency-related typo introduced in the previous commit [1]
- Added BSD license - Added more checks for valid option combinations - Bumped PORTREVISION PR: ports/153761 Submitted by: Anatoly Borodin <anatoly.borodin@gmail.com> [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/viewvc/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index 6f4693fda195..86ca8a55c282 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= viewvc
PORTVERSION= 1.1.8
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.viewvc.org/ \
LOCAL/glarkin
@@ -32,6 +33,8 @@ SUB_LIST= INSTDIR="${PREFIX}/${INSTDIR}" \
INSTDIR?= ${PORTNAME}
PLIST_SUB= INSTDIR=${INSTDIR}
+LICENSE= BSD
+
.include <bsd.port.options.mk>
.if !defined(WITH_APACHE) && !defined(WITH_LIGHTTPD)
@@ -66,12 +69,12 @@ RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi3
# It catalogs every commit in the CVS or Subversion repository into a SQL database.
# In fact, the databases are 100% compatible.
.if defined(WITH_MYSQL)
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}-MySQLdb>=0::${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
.endif
pre-everything::
.if defined(WITH_APACHE) && defined(WITH_LIGHTTPD)
- @${ECHO_CMD} "It doesn't make sense to depend on Apache *and* lighttpd choose only one."
+ @${ECHO_CMD} "It doesn't make sense to depend on Apache *and* lighttpd - choose only one."
@${FALSE}
.endif
@@ -81,6 +84,12 @@ pre-everything::
.elif defined(WITH_MODPYTHON3) && !defined(WITH_APACHE)
@${ECHO_CMD} "mod_python3 needs Apache, please select Apache"
@${FALSE}
+.elif defined(WITH_MODWSGI3) && !defined(WITH_APACHE) && defined(WITH_LIGHTTPD)
+ @${ECHO_CMD} "mod_wsgi3 needs Apache, please select Apache and deselect lighttpd"
+ @${FALSE}
+.elif defined(WITH_MODWSGI3) && !defined(WITH_APACHE)
+ @${ECHO_CMD} "mod_wsgi3 needs Apache, please select Apache"
+ @${FALSE}
.endif
do-install: