aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-07-04 18:00:00 +0800
committerlofi <lofi@FreeBSD.org>2007-07-04 18:00:00 +0800
commitc379f4631f0ca9aff2a4863e27927e194d880f97 (patch)
tree2068b4fc2a37bc3b190c7f0e9b0149e838e14df4 /devel
parent4cf232cedccfe8ccb3b93f0d1a52345b393c24e5 (diff)
downloadfreebsd-ports-gnome-c379f4631f0ca9aff2a4863e27927e194d880f97.tar.gz
freebsd-ports-gnome-c379f4631f0ca9aff2a4863e27927e194d880f97.tar.zst
freebsd-ports-gnome-c379f4631f0ca9aff2a4863e27927e194d880f97.zip
Set CONFLICTS, don't hide the shared libary from the runtime linker.
Diffstat (limited to 'devel')
-rw-r--r--devel/libopensync/Makefile4
-rw-r--r--devel/libopensync/pkg-plist1
-rw-r--r--devel/libopensync022/Makefile3
3 files changed, 8 insertions, 0 deletions
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
index ca247c1c3848..7d55076cf5fe 100644
--- a/devel/libopensync/Makefile
+++ b/devel/libopensync/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libopensync
PORTVERSION= 0.30
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.opensync.org/attachment/wiki/download/
DISTNAME= libopensync-${PORTVERSION}
@@ -15,6 +16,8 @@ EXTRACT_SUFX= .tar.bz2\?rev=\&format=raw
MAINTAINER= ports@FreeBSD.org
COMMENT= A PIM data synchronization framework
+CONFLICTS= libopensync-0.22*
+
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
USE_BZIP2= yes
@@ -28,6 +31,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gthread-2.0|gthread-2.0 pthread|' ${WRKSRC}/opensync/SConscript
post-install:
+ @${LN} -sf ${LOCALBASE}/lib/libopensync.so ${LOCALBASE}/lib/libopensync.so.1
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/devel/libopensync/pkg-plist b/devel/libopensync/pkg-plist
index 79d660cd5a70..f5a5a251b920 100644
--- a/devel/libopensync/pkg-plist
+++ b/devel/libopensync/pkg-plist
@@ -57,6 +57,7 @@ include/opensync-1.0/opensync/plugin/opensync_plugin_info.h
include/opensync-1.0/opensync/plugin/opensync_sink.h
include/opensync-1.0/opensync/version/opensync_version.h
lib/libopensync.so
+lib/libopensync.so.1
lib/opensync/formats/libdata.so
lib/opensync/formats/libfile.so
lib/opensync/formats/libxmlformat-doc.so
diff --git a/devel/libopensync022/Makefile b/devel/libopensync022/Makefile
index da4a13401496..50366f11e7f0 100644
--- a/devel/libopensync022/Makefile
+++ b/devel/libopensync022/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libopensync
PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.opensync.org/attachment/wiki/download/
EXTRACT_SUFX= .tar.bz2\?rev=\&format=raw
@@ -14,6 +15,8 @@ EXTRACT_SUFX= .tar.bz2\?rev=\&format=raw
MAINTAINER= ports@FreeBSD.org
COMMENT= Freedesktop synchronization framework
+CONFLICTS= libopensync-0.[3-9]*
+
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
RUN_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13