aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-09 09:32:00 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-09 09:32:00 +0800
commitc5e4f13126b2cb16022741d11fe399fe46d44c92 (patch)
treebe89f3fe24511c9b98e4451339d0fcd23c3c1e15 /devel
parente4dc36673245972ddd2913cafd67976c4caec4f9 (diff)
downloadfreebsd-ports-gnome-c5e4f13126b2cb16022741d11fe399fe46d44c92.tar.gz
freebsd-ports-gnome-c5e4f13126b2cb16022741d11fe399fe46d44c92.tar.zst
freebsd-ports-gnome-c5e4f13126b2cb16022741d11fe399fe46d44c92.zip
- Add p5-true 0.18
Perl's require builtin (and its use wrapper) requires the files it loads to return a true value. This is usually accomplished by placing a single 1; statement at the end of included scripts or modules. It's not onerous to add but it's a speed bump on the Perl novice's road to enlightenment. In addition, it appears to be a non-sequitur to the uninitiated, leading some to attempt to mitigate its appearance with a comment: 1; # keep require happy or: 1; # Do not remove this line or even: 1; # Must end with this, because Perl is bogus. This module packages this "return true" behaviour so that it need not be written explicitly. It can be used directly, but it is intended to be invoked from the import method of a Modern::Perl-style module that enables modern Perl features and conveniences and cleans up legacy Perl warts. WWW: http://search.cpan.org/dist/true/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-true/Makefile31
-rw-r--r--devel/p5-true/distinfo2
-rw-r--r--devel/p5-true/pkg-descr22
-rw-r--r--devel/p5-true/pkg-plist7
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0d85c9027482..bc5abc6f88eb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2642,6 +2642,7 @@
SUBDIR += p5-subversion
SUBDIR += p5-threads
SUBDIR += p5-threads-shared
+ SUBDIR += p5-true
SUBDIR += p5-uni-perl
SUBDIR += p5-version
SUBDIR += p65
diff --git a/devel/p5-true/Makefile b/devel/p5-true/Makefile
new file mode 100644
index 000000000000..aaaa87a09862
--- /dev/null
+++ b/devel/p5-true/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-true
+# Date created: 2011-11-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= true
+PORTVERSION= 0.18
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CHOCOLATE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Automatically return a true value when a file is required
+
+BUILD_DEPENDS= p5-B-Hooks-OP-Annotation>=0.43:${PORTSDIR}/devel/p5-B-Hooks-OP-Annotation \
+ p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-Devel-StackTrace>=1.27:${PORTSDIR}/devel/p5-Devel-StackTrace \
+ p5-ExtUtils-Depends>=0.304:${PORTSDIR}/devel/p5-ExtUtils-Depends
+RUN_DEPENDS= p5-B-Hooks-OP-Annotation>=0.43:${PORTSDIR}/devel/p5-B-Hooks-OP-Annotation \
+ p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-Devel-StackTrace>=1.27:${PORTSDIR}/devel/p5-Devel-StackTrace
+
+PERL_CONFIGURE= yes
+
+MAN3= true.3 \
+ true::VERSION.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-true/distinfo b/devel/p5-true/distinfo
new file mode 100644
index 000000000000..9b988b2dfbd1
--- /dev/null
+++ b/devel/p5-true/distinfo
@@ -0,0 +1,2 @@
+SHA256 (true-0.18.tar.gz) = ff3d041eb2a522ec6194d7a3888325e8a3ef2238ab51452f0b547696be0b4594
+SIZE (true-0.18.tar.gz) = 51382
diff --git a/devel/p5-true/pkg-descr b/devel/p5-true/pkg-descr
new file mode 100644
index 000000000000..f590ada08ea8
--- /dev/null
+++ b/devel/p5-true/pkg-descr
@@ -0,0 +1,22 @@
+Perl's require builtin (and its use wrapper) requires the files it loads to
+return a true value. This is usually accomplished by placing a single
+
+ 1;
+
+statement at the end of included scripts or modules. It's not onerous to add but
+it's a speed bump on the Perl novice's road to enlightenment. In addition, it
+appears to be a non-sequitur to the uninitiated, leading some to attempt to
+mitigate its appearance with a comment:
+
+ 1; # keep require happy
+or:
+ 1; # Do not remove this line
+or even:
+ 1; # Must end with this, because Perl is bogus.
+
+This module packages this "return true" behaviour so that it need not be written
+explicitly. It can be used directly, but it is intended to be invoked from the
+import method of a Modern::Perl-style module that enables modern Perl features
+and conveniences and cleans up legacy Perl warts.
+
+WWW: http://search.cpan.org/dist/true/
diff --git a/devel/p5-true/pkg-plist b/devel/p5-true/pkg-plist
new file mode 100644
index 000000000000..4b54dea46e43
--- /dev/null
+++ b/devel/p5-true/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/true/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/true/true.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/true/true.so
+%%SITE_PERL%%/%%PERL_ARCH%%/true.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/true/VERSION.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/true