aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2008-01-11 01:32:35 +0800
committerlwhsu <lwhsu@FreeBSD.org>2008-01-11 01:32:35 +0800
commitc6348880a85591acda5e3eb43b411ad367e0b0b7 (patch)
tree412a2d8a6c03eedf264d4763cf060773ab08e1dd /devel
parentbf355073ae8b49934c2d4ec40238ed6757fd6885 (diff)
downloadfreebsd-ports-gnome-c6348880a85591acda5e3eb43b411ad367e0b0b7.tar.gz
freebsd-ports-gnome-c6348880a85591acda5e3eb43b411ad367e0b0b7.tar.zst
freebsd-ports-gnome-c6348880a85591acda5e3eb43b411ad367e0b0b7.zip
Add py-polib 0.3.1, a python library to parse and manage gettext
catalogs. PR: ports/119527 Submitted by: Oleg Ukraincev <oleg at ht-systems.ru>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-polib/Makefile20
-rw-r--r--devel/py-polib/distinfo3
-rw-r--r--devel/py-polib/pkg-descr13
-rw-r--r--devel/py-polib/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0be79562e9a3..5e3b6e68f55a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1975,6 +1975,7 @@
SUBDIR += py-plex
SUBDIR += py-ply
SUBDIR += py-pmock
+ SUBDIR += py-polib
SUBDIR += py-pp
SUBDIR += py-pqueue
SUBDIR += py-protocols
diff --git a/devel/py-polib/Makefile b/devel/py-polib/Makefile
new file mode 100644
index 000000000000..06a3b3498411
--- /dev/null
+++ b/devel/py-polib/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-polib
+# Date created: 10 January 2008
+# Whom: Oleg Ukraincev <oleg@ht-systems.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= polib
+PORTVERSION= 0.3.1
+CATEGORIES= devel python
+MASTER_SITES= http://polib.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= oleg@ht-systems.ru
+COMMENT= A python library to parse and manage gettext catalogs
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-polib/distinfo b/devel/py-polib/distinfo
new file mode 100644
index 000000000000..9d7778a1944f
--- /dev/null
+++ b/devel/py-polib/distinfo
@@ -0,0 +1,3 @@
+MD5 (polib-0.3.1.tar.gz) = d8bcd87efe252ff7daef940c94a40279
+SHA256 (polib-0.3.1.tar.gz) = 53c3348c5b03d1059480033a35646fcf37ebf4066034a0ef81dfbc822f67160e
+SIZE (polib-0.3.1.tar.gz) = 206897
diff --git a/devel/py-polib/pkg-descr b/devel/py-polib/pkg-descr
new file mode 100644
index 000000000000..626f042ac27d
--- /dev/null
+++ b/devel/py-polib/pkg-descr
@@ -0,0 +1,13 @@
+PoLib is a python library to parse and manage gettext catalogs.
+
+polib allows you to manipulate, create, modify gettext files
+(pot, po and mo files). You can load existing files, iterate
+through it's entries, add, modify entries, comments or metadata, etc...
+or create new po files from scratch.
+
+polib provides a simple and pythonic API, exporting only three
+convenience functions 'pofile', 'mofile' and 'detect_encoding',
+and the 4 core classes: POFile, MOFile, POEntry and MOEntry for
+creating new files/entries.
+
+WWW: http://polib.googlecode.com/
diff --git a/devel/py-polib/pkg-plist b/devel/py-polib/pkg-plist
new file mode 100644
index 000000000000..c7788d5ffc82
--- /dev/null
+++ b/devel/py-polib/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/polib.py
+%%PYTHON_SITELIBDIR%%/polib.pyc
+%%PYTHON_SITELIBDIR%%/polib.pyo