aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-09-20 17:53:08 +0800
committerbapt <bapt@FreeBSD.org>2011-09-20 17:53:08 +0800
commitcc43312e58c0eace61c11a237f19eb97aa410715 (patch)
tree457d08168913720d418bdd9ed262d37a4aa99b37 /devel
parentc880943dd65d7575539d097f333439c6c6f510b4 (diff)
downloadfreebsd-ports-gnome-cc43312e58c0eace61c11a237f19eb97aa410715.tar.gz
freebsd-ports-gnome-cc43312e58c0eace61c11a237f19eb97aa410715.tar.zst
freebsd-ports-gnome-cc43312e58c0eace61c11a237f19eb97aa410715.zip
CPAN::Uploader - upload things to the CPAN
WWW: http://search.cpan.org/dist/CPAN-Uploader/ Submitted by: Geraud CONTINSOUZAS <geraud@gcu.info> (by private mail)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-CPAN-Uploader/Makefile31
-rw-r--r--devel/p5-CPAN-Uploader/Makefile~31
-rw-r--r--devel/p5-CPAN-Uploader/distinfo2
-rw-r--r--devel/p5-CPAN-Uploader/pkg-descr3
-rw-r--r--devel/p5-CPAN-Uploader/pkg-plist6
6 files changed, 74 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a9762cb01af0..30a9ea38ead0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1258,6 +1258,7 @@
SUBDIR += p5-CPAN-Reporter-Smoker
SUBDIR += p5-CPAN-SQLite
SUBDIR += p5-CPAN-Testers-Report
+ SUBDIR += p5-CPAN-Uploader
SUBDIR += p5-CPAN-YACSmoke
SUBDIR += p5-CPANPLUS
SUBDIR += p5-CPANPLUS-Dist-Build
diff --git a/devel/p5-CPAN-Uploader/Makefile b/devel/p5-CPAN-Uploader/Makefile
new file mode 100644
index 000000000000..8def032cb31d
--- /dev/null
+++ b/devel/p5-CPAN-Uploader/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-CPAN-Uploader
+# Date created: 2011-09-19
+# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CPAN-Uploader
+PORTVERSION= 0.103000
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= geraud@gcu.info
+COMMENT= Upload things to the CPAN
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Getopt-Long-Descriptive>=0.084:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= cpan-upload.1
+MAN3= CPAN::Uploader.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Uploader/Makefile~ b/devel/p5-CPAN-Uploader/Makefile~
new file mode 100644
index 000000000000..8def032cb31d
--- /dev/null
+++ b/devel/p5-CPAN-Uploader/Makefile~
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-CPAN-Uploader
+# Date created: 2011-09-19
+# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CPAN-Uploader
+PORTVERSION= 0.103000
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= geraud@gcu.info
+COMMENT= Upload things to the CPAN
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Getopt-Long-Descriptive>=0.084:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= cpan-upload.1
+MAN3= CPAN::Uploader.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Uploader/distinfo b/devel/p5-CPAN-Uploader/distinfo
new file mode 100644
index 000000000000..c1512b090d35
--- /dev/null
+++ b/devel/p5-CPAN-Uploader/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CPAN-Uploader-0.103000.tar.gz) = d5a451c030ddcba37ed540f2bca60adaabb110d69be9d93e8ab9492a5d8adf5f
+SIZE (CPAN-Uploader-0.103000.tar.gz) = 13658
diff --git a/devel/p5-CPAN-Uploader/pkg-descr b/devel/p5-CPAN-Uploader/pkg-descr
new file mode 100644
index 000000000000..5099bdf6a2d2
--- /dev/null
+++ b/devel/p5-CPAN-Uploader/pkg-descr
@@ -0,0 +1,3 @@
+CPAN::Uploader - upload things to the CPAN
+
+WWW: http://search.cpan.org/dist/CPAN-Uploader/
diff --git a/devel/p5-CPAN-Uploader/pkg-plist b/devel/p5-CPAN-Uploader/pkg-plist
new file mode 100644
index 000000000000..ec3470056519
--- /dev/null
+++ b/devel/p5-CPAN-Uploader/pkg-plist
@@ -0,0 +1,6 @@
+bin/cpan-upload
+%%SITE_PERL%%/CPAN/Uploader.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Uploader/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN/Uploader
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CPAN
+@dirrmtry %%SITE_PERL%%/CPAN