aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-11-09 02:18:08 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-11-09 02:18:08 +0800
commitcc6520c0513e99caa3025b17c0dc95980fc25749 (patch)
tree992a6416f34a76cf533537e96e2b2bf2ddabfb6f /devel
parent5e6f34759929a14ebaee86fbd15568a2cc58f122 (diff)
downloadfreebsd-ports-gnome-cc6520c0513e99caa3025b17c0dc95980fc25749.tar.gz
freebsd-ports-gnome-cc6520c0513e99caa3025b17c0dc95980fc25749.tar.zst
freebsd-ports-gnome-cc6520c0513e99caa3025b17c0dc95980fc25749.zip
- Update to 0.0.5
- Support staging - Fix options - Fix build on current - Convert USE_GMAKE to USES
Diffstat (limited to 'devel')
-rw-r--r--devel/pire/Makefile22
-rw-r--r--devel/pire/distinfo4
-rw-r--r--devel/pire/files/patch-pire_glue.cpp11
-rw-r--r--devel/pire/files/patch-pire_stub_saveload.h20
-rw-r--r--devel/pire/files/patch-samples_pigrep_pigrep.cpp10
-rw-r--r--devel/pire/files/patch-tools_bench_bench.cpp10
-rw-r--r--devel/pire/pkg-plist9
7 files changed, 24 insertions, 62 deletions
diff --git a/devel/pire/Makefile b/devel/pire/Makefile
index 53df9c0b4fef..a04d99f25a42 100644
--- a/devel/pire/Makefile
+++ b/devel/pire/Makefile
@@ -2,36 +2,42 @@
# $FreeBSD$
PORTNAME= pire
-PORTVERSION= 0.0.4
+PORTVERSION= 0.0.5
CATEGORIES= devel
-MASTER_SITES= http://cloud.github.com/downloads/dprokoptsev/${PORTNAME}/ \
- http://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Perl Incompatible Regular Expressions library
+USE_GITHUB= yes
+GH_ACCOUNT= dprokoptsev
+GH_TAGNAME= release-${PORTVERSION}
+GH_COMMIT= 012bedf
+
LICENSE= LGPL3
-LICENSE_FILE= ${WRKSRC}/COPYING
+USE_AUTOTOOLS= autoconf automake libtool libtoolize
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake bison
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= amd64 i386 ia64
ONLY_FOR_ARCHS_REASON= not yet ported to big-endian platforms
OPTIONS_DEFINE= UNITTEST
-OPTIONS_UNITTEST_DESC= Compile with unittest support
+UNITTEST_DESC= Compile with unittest support
-NO_STAGE= yes
.include <bsd.port.options.mk>
+run-autotools:
+ @cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -fi
+
.if ${PORT_OPTIONS:MUNITTEST} || defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
CONFIGURE_ARGS= --with-cppunit-prefix=${LOCALBASE}
regression-test:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check || \
+ (${CAT} ${WRKSRC}/tests/test-suite.log; false)
.endif
.include <bsd.port.mk>
diff --git a/devel/pire/distinfo b/devel/pire/distinfo
index 38f7d9210a3a..59ee58b0d90c 100644
--- a/devel/pire/distinfo
+++ b/devel/pire/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pire-0.0.4.tar.gz) = 667b3c15580ab5ba4469e857d329c9d1be254d86db0b4ebd7ad408988959847b
-SIZE (pire-0.0.4.tar.gz) = 487142
+SHA256 (pire-0.0.5.tar.gz) = 0285b90d497e424e2f52ab2608745e03b7e2e2f121993aee08ac5543b2c5a786
+SIZE (pire-0.0.5.tar.gz) = 149072
diff --git a/devel/pire/files/patch-pire_glue.cpp b/devel/pire/files/patch-pire_glue.cpp
deleted file mode 100644
index 5ac31fae9b95..000000000000
--- a/devel/pire/files/patch-pire_glue.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- pire/glue.cpp.orig 2010-11-16 23:42:09.000000000 +0000
-+++ pire/glue.cpp
-@@ -60,7 +60,7 @@ public:
- size_t finalTableSize = 0;
- for (typename yvector<State>::const_iterator i = states.begin(), ie = states.end(); i != ie; ++i)
- finalTableSize += RangeLen(Lhs().AcceptedRegexps(i->first)) + RangeLen(Rhs().AcceptedRegexps(i->second));
-- SetSc(new Scanner);
-+ this->SetSc(new Scanner);
- Sc().Init(states.size(), Letters(), finalTableSize, size_t(0), Lhs().RegexpsCount() + Rhs().RegexpsCount());
-
- for (size_t state = 0; state != states.size(); ++state) {
diff --git a/devel/pire/files/patch-pire_stub_saveload.h b/devel/pire/files/patch-pire_stub_saveload.h
deleted file mode 100644
index b572b914ba86..000000000000
--- a/devel/pire/files/patch-pire_stub_saveload.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- pire/stub/saveload.h.orig 2010-11-16 23:42:09.000000000 +0000
-+++ pire/stub/saveload.h
-@@ -52,7 +52,7 @@ namespace Pire {
- if (!Traits::eq_int_type(ret, Traits::eof())) {
- m_ch = (Char) ret;
- m_read += sizeof(Char);
-- setg(&m_ch, &m_ch, &m_ch+1);
-+ this->setg(&m_ch, &m_ch, &m_ch+1);
- }
- return ret;
- }
-@@ -117,7 +117,7 @@ namespace Pire {
- BasicAlignedOutput(std::basic_ostream<Char, Traits>* backend)
- : m_streambuf(backend->rdbuf())
- {
-- rdbuf(&m_streambuf);
-+ this->rdbuf(&m_streambuf);
- }
-
- void Align(size_t divisor = sizeof(void*))
diff --git a/devel/pire/files/patch-samples_pigrep_pigrep.cpp b/devel/pire/files/patch-samples_pigrep_pigrep.cpp
deleted file mode 100644
index 8c456602f749..000000000000
--- a/devel/pire/files/patch-samples_pigrep_pigrep.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- samples/pigrep/pigrep.cpp.orig 2010-11-16 23:42:09.000000000 +0000
-+++ samples/pigrep/pigrep.cpp
-@@ -29,6 +29,7 @@
-
- #include <string.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include <string>
- #include <stdexcept>
- #include <iostream>
diff --git a/devel/pire/files/patch-tools_bench_bench.cpp b/devel/pire/files/patch-tools_bench_bench.cpp
deleted file mode 100644
index 88bd60a9c7ff..000000000000
--- a/devel/pire/files/patch-tools_bench_bench.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/bench/bench.cpp.orig 2010-11-16 23:42:09.000000000 +0000
-+++ tools/bench/bench.cpp
-@@ -23,6 +23,7 @@
-
- #include <fcntl.h>
- #include <errno.h>
-+#include <unistd.h>
- #include <sys/stat.h>
- #include <sys/mman.h>
- #include <sys/time.h>
diff --git a/devel/pire/pkg-plist b/devel/pire/pkg-plist
index c89018c027b1..f0a1f18abd85 100644
--- a/devel/pire/pkg-plist
+++ b/devel/pire/pkg-plist
@@ -2,8 +2,10 @@ bin/pigrep
bin/pire_inline
include/pire/align.h
include/pire/any.h
+include/pire/config.h
include/pire/defs.h
include/pire/determine.h
+include/pire/easy.h
include/pire/encoding.h
include/pire/extra.h
include/pire/fsm.h
@@ -11,6 +13,7 @@ include/pire/fwd.h
include/pire/glue.h
include/pire/partition.h
include/pire/pire.h
+include/pire/platform.h
include/pire/re_lexer.h
include/pire/re_parser.h
include/pire/run.h
@@ -20,10 +23,10 @@ include/pire/scanners/multi.h
include/pire/scanners/pair.h
include/pire/scanners/simple.h
include/pire/scanners/slow.h
-include/pire/sse.h
include/pire/static_assert.h
include/pire/stub/defaults.h
include/pire/stub/lexical_cast.h
+include/pire/stub/memstreams.h
include/pire/stub/saveload.h
include/pire/stub/singleton.h
include/pire/stub/stl.h
@@ -32,6 +35,10 @@ lib/libpire.a
lib/libpire.la
lib/libpire.so
lib/libpire.so.0
+lib/libpire_unit.a
+lib/libpire_unit.la
+lib/libpire_unit.so
+lib/libpire_unit.so.0
@dirrm include/pire/stub
@dirrm include/pire/scanners
@dirrm include/pire