aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-18 19:40:04 +0800
committerbapt <bapt@FreeBSD.org>2013-03-18 19:40:04 +0800
commitcd6cb91f6fc3a0aea1f5f46650af0a4b87487f59 (patch)
tree6b707abf8d8621e9bcb4f385129f5e95769e9154 /devel
parent884ad2690ee76c497ad1c40bb4dac951731a4bbb (diff)
downloadfreebsd-ports-gnome-cd6cb91f6fc3a0aea1f5f46650af0a4b87487f59.tar.gz
freebsd-ports-gnome-cd6cb91f6fc3a0aea1f5f46650af0a4b87487f59.tar.zst
freebsd-ports-gnome-cd6cb91f6fc3a0aea1f5f46650af0a4b87487f59.zip
Fix a long standing bug of lib/charset.alias being overwritten, modified, and badly tracked by ports.
Make lib/charset.alias a file only provided by converters/libiconv Create a new USES: charsetfix, that will modify in post patch the Makefile.in to prevent a port from modifying/overwritting the charset.alias file during make install. Prevent devel/gettext from installing that files. Fix a couple of ports that actually touch charset.alias during the build phase. Based on a patch by ale (http://lists.freebsd.org/pipermail/freebsd-gnome/2012-October/027747.html) Approved by: kwm (gnome) Exp-run by: miwi
Diffstat (limited to 'devel')
-rw-r--r--devel/bison/Makefile1
-rw-r--r--devel/gettext/Makefile8
-rw-r--r--devel/gettext/pkg-plist1
-rw-r--r--devel/libunistring/Makefile7
-rw-r--r--devel/libvirt/Makefile2
-rw-r--r--devel/patch/Makefile7
6 files changed, 9 insertions, 17 deletions
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 8398dcbec053..74c36b4ef6aa 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -14,6 +14,7 @@ COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USES= charsetfix
USE_XZ= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index dc58f03bb69d..a43c72bad849 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: gettext
-# Date created: 16 March 1998
-# Whom: Yukihiro Nakai <Nakai@technologist.com>
-#
+# Created by: Yukihiro Nakai <Nakai@technologist.com>
# $FreeBSD$
-#
PORTNAME= gettext
PORTVERSION= 0.18.1.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gettext
@@ -17,6 +14,7 @@ MASTER_SITE_SUBDIR= gettext
MAINTAINER= autotools@FreeBSD.org
COMMENT= GNU gettext package
+USES= charsetfix
USE_ICONV= yes
LIBTOOLFILES= gettext-runtime/configure \
gettext-runtime/libasprintf/configure gettext-tools/configure
diff --git a/devel/gettext/pkg-plist b/devel/gettext/pkg-plist
index ffbbc5abce7a..c8ba969c9385 100644
--- a/devel/gettext/pkg-plist
+++ b/devel/gettext/pkg-plist
@@ -25,7 +25,6 @@ include/autosprintf.h
include/gettext-po.h
include/libintl.h
@exec /bin/mkdir -p %D/lib/gettext
-lib/charset.alias
lib/libasprintf.a
lib/libasprintf.la
lib/libasprintf.so
diff --git a/devel/libunistring/Makefile b/devel/libunistring/Makefile
index 173188c5ffb4..da140351dc68 100644
--- a/devel/libunistring/Makefile
+++ b/devel/libunistring/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libunistring
-# Date created: 2011-05-17
-# Whom: Takefu
-#
+# Created by: Takefu
# $FreeBSD$
-#
PORTNAME= libunistring
PORTVERSION= 0.9.3
@@ -18,6 +14,7 @@ LICENSE_COMB= dual
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
+USES= charsetfix
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 35fad37a7086..503c5e6200f3 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -39,8 +39,8 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+USES= charsetfix pathfix
USE_GMAKE= yes
-USE_GNOME= gnomehack
GNOME_MAKEFILEIN= Makefile.in
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
index 55235cc4c6d3..acf610e48faf 100644
--- a/devel/patch/Makefile
+++ b/devel/patch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: patch
-# Date created: 21 Jan 1998
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= patch
PORTVERSION= 2.7
@@ -21,6 +17,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-prefix=g
USE_GMAKE= yes
USE_XZ= yes
+USES= charsetfix
MAN1= gpatch.1
PLIST_FILES= bin/gpatch